Php 8.1 vs Php 7.4

Bonjour,
Travaillant également avec WordPress 6.0.2 j'ai mis à jour mon hébergement pour utiliser Php 8.1.
Par contre dans le cas de PluXml 5.8.9, quelles sont les précautions à prendre ou les bugs relevés si on héberge PluXml avec Php 8.1.
Régulièrement on parle sur le forum d'une version PluXml 6.0 qui serait compatible avec Php 8.1?
Dans mes thèmes j'utilise :
`````
<?php if (!defined('PLX_ROOT')) exit; ?>
define('PLS_PARTS', ROOT_THEME.'/template-parts');

<?php include(PLS_PARTS.'/header/site-navigation') ?>
````
Est-ce correct? Ou bien dois-je utiliser un autre code plus conforme avec Php 8.1 ou PluXml 5.8.9
Cordialement

Réponses

  • P3terP3ter PluXml Project Manager

    Bonjour,
    Pour répondre à ta question sur la compatibilité avec PHP 8.1, il y a eu des corrections dans les versions 5.8.7 et 5.8.8 de PluXml à ce sujet. Actuellement pluxml.org tourne sur PluXml 5.8.9 et PHP 8.1.9. Je n'ai pas rencontré de problème jusqu'à maintenant.

  • FreesbyFreesby Member

    Bonjour
    Après un test très rapide php 8.1 (hébergeur O.V.H) fonctionne bien avec pluxml,
    par contre de il ne fonctionne pas avec le plugin plxMyShop version 1.0.4.
    Bonne journée

Connectez-vous ou Inscrivez-vous pour répondre.