PluXml 5.8.9 : Problèmes avec ArtGalerie (Rockyhorror)

bg62bg62 Member

bjr
je tourne actuellement avec cette versions :-1: <?xml version="1.0" encoding="UTF-8"?>

<![CDATA[ArtGalerie]]>
<![CDATA[Rockyhorror]]>
4.3
21/07/2015
http://thepoulpe.net
<![CDATA[Ajout de galerie d'images à vos articles]]>


et depuis la récente mise à jour j'ai ce message:
" Notice: Undefined index: attributes in G:\laragon\www\www.unesourisetmoi.infoNEW\plugins\artGalerie\artGalerie.php on line 220 "
lorsque je veux ouvrir une galerie

Réponses

  • Bonjour,

    Depuis quelle version de PluXml fais tu cette mise à jour ?
    Quelle version de php utilises tu?

    As tu essayé de désinstaller puis réinstaller (ou désactiver/activer) ?

    Ta ligne 220 recherche apparemment dans un tableau un champ "attributes" . A quoi ressemble cette ligne ?
    etc...

    Pour le moment le site http://thepoulpe.net/ semble inaccessible. L'archive de ce plugin se trouve t-elle ailleurs ?

    Cdt

    ♣♣♣♣ <°(((((-{ ~ Mon site avec PluXml: https://re7net.com | Mes plugins : https://github.com/gcyrillus PluXml 5.8.7 sur free ? oui c'est possible : http://gcyrillus.free.fr/new }-))))°> ♣♣♣♣

  • bazooka07bazooka07 PluXml Project Manager

    @gcyrillus-nomade,
    Au fin fonds de mon disque dur, j'ai la version 4.5 du plugin artgalerie datée du 22/11/2016.
    Je l'ai mis sur mon dépôt de plugins, sans aucune garantie que cela marche avec PluXml 5.8.9 :
    https://kazimentou.fr/repo/index.php?plugin=artGalerie&download

  • 4 nov. modifié

    @bazooka07 merci

    @bg62 je viens de tester la version4.5 avec le dernier jQuery , pas de message d'erreur et affichage de galerie okay. (sauf zoombox qui freeze , nivo-slider qui n'affiche rien et PrettyPhotos apparemment incomplet dans ces fonctionnalités , bogues surement lié à la version de jQuery trop récente pour ce plugin qui à déjà 6ans)

    en gros : ArtGalerie 4.5 compatible PluXml 5.8.9, jQuery 3.6.1 et php 8.1.5 (jQuery 1.9.1 préconisé pour les plugins d'affichage de la galerie)

    Est tu certains que ta mise à jour a bien ecrasé/remplacé tout les fichiers ?

    ♣♣♣♣ <°(((((-{ ~ Mon site avec PluXml: https://re7net.com | Mes plugins : https://github.com/gcyrillus PluXml 5.8.7 sur free ? oui c'est possible : http://gcyrillus.free.fr/new }-))))°> ♣♣♣♣

  • bg62bg62 Member

    version actuelle de PluXml : 5.5
    pour la version de php : PHP Version 7.4.19 (en local )
    pour le plugin "
    si je le désactive les images ou galeries s'affichent dans l'admin sans sousis, mais bien sûr ne s'affichent plus
    ( Notice: Trying to access array offset on value of type null in G:\laragon\www\www.unesourisetmoi.infoNEW\core\lib\class.plx.motor.php on line 735
    ) une fois réactivé il semble continuer de fonctionner des deux côtés ... :)
    Pour cette ligne 220, la voici :
    $this->aGalerie[$values[$v]['attributes']['name']] = plxUtils::getValue($values[$v]['value']);
    je pense donc que e doit être bon maintenant, je vais aussi voir du côté des plugins si je suis bien à jour de ce côté là .....

    Ce plugin avait été qq peu personnalisé par son auteur pour une meilleure prise en compte seo des images et de leurs baises, si vous le voulez je peux le mettre en zip quelque part ?

    grands merci à tous les deux

Connectez-vous ou Inscrivez-vous pour répondre.