PluCSS le framework CSS pour PluXml

2»

Réponses

  • Il faudrait ajouter un
    width:100%
    
    ligne 712 avant le max-width afin d'éviter l'affichage d'une barre de scroll horizontale.
  • JosJos Membres
    Jerry Wham a écrit:
    Il faudrait ajouter un
    width:100%
    
    ligne 712 avant le max-width afin d'éviter l'affichage d'une barre de scroll horizontale.

    Salut,

    A quel endroit tu vois une barre horizontale sur le container?
  • Sur un projet tout neuf qui n'est pas basé sur Pluxml mais pour lequel j'utilise PluCSS. Je n'ai pas le code sous la main aujourd'hui mais je te posterai la structure de la page.
    La barre apparait lorsqu'on redimensionne manuellement la fenêtre. Elle disparait si on applique un width à 100%.
  • JosJos Membres
    janvier 2015 modifié
    Ca y est.... j'ai compris et réussit à reproduire le soucis. Ça ne se produit pas à chaque fois, mais c'est possible que çà apparaisse. J'ai ajouté ta correction dans le dépôt GitHub de PluCSS. Il sera appliqué sur la prochaine version de PluCSS.

    J'ai été long à la détente cette fois... :)

    Merci beaucoup.
  • Encore une fois merci à l'équipe qui met son savoir-faire au service des autres.

    Excellent projet, que je vais probablement utilisé :cool: .
  • JosJos Membres
    Merci. Le projet va continuer à évoluer.
  • JosJos Membres
    avril 2015 modifié
    Bonjour à tous,

    Attention à celles eu ceux qui utilisent PluCSS : la version GitHub a été mise à jour pour vous proposer un nouveau système de formulaire. La prochaine version a également mise à jour.

    Si vous mettez à jour PluCSS à partir de GitHub, vous risquez d'avoir des bugs sur vos formulaires.

    J'ai mis à jour la documentation, elle sera bientôt en ligne.

    J'ai également modifié pas mal d'autres points qui ne devraient pas avoir de conséquences.
  • Pourquoi avoir viré les tags ???
  • JosJos Membres
    Les classes de tags étant des classes propres au thème par défaut, je les aies mis dans theme.css. Je réflechis encore à çà car j'ai un bug non résolu encore de ce coté là.
  • TonherTonher Membres
    Bonjour,

    Juste un petit mot d'encouragement en passant par là, pour ce projet et le travail déjà accompli.

    Merci

    @++
  • JosJos Membres
    Merci. Il est vrai qu'on s'est lancé dans un "sacré chantier". Mais on touche au but...
  • JosJos Membres
    Jos a écrit:
    Les classes de tags étant des classes propres au thème par défaut, je les aies mis dans theme.css. Je réflechis encore à çà car j'ai un bug non résolu encore de ce coté là.

    Bonjour,

    Je me cite moi-même. Juste pour vous informer que ce bug que j'avais signalé viens d'être corrigé.
  • DeevadDeevad Membres
    Bonjour, juste un petit mot de retour de la part d'un 'bidouilleur de thème' qui c'est toujours casser le nez sur le 'responsive' et qui vient d'adopter PluCss; la doc ( http://plucss.pluxml.org/index.php ) est un plaisir pour travailler, les noms de classes sont astucieux ( les Helpers <3 ) et PluCss permet un travail d'une grande flexibilité et créativité. Bravo Jos et Stéphane. C'est top qualité.

    Note: voici un petit bout de code que je copie dans mes html de prototypes ; il est bien utile pour savoir dans quel mode ( 'sml' , 'med' ou 'lrg' ) le thème se trouve. Avec la fonction Ctrl+Shift+M de Firefox, je me régale.
    [== HTML ==]
    <!-- Debug info -->
    <div style="position: fixed; right: 0px; bottom: 0px; background: #FFF8BB; color: #B27951; z-index: 500 !important;">
        <div class="sml-show med-hide lrg-hide"> SML </div>
        <div class="sml-hide med-show lrg-hide"> MED </div>
        <div class="sml-hide med-hide lrg-show"> LRG </div>
    </div>
    
  • Pas con. Merci pour le partage {)
  • ScithScith Membres
    Salut et merci pour ce framework que je suis en train d'appliquer sur un thème :)
    Quelques questions svp :

    Pourquoi les éléments grid ont-ils : margin-left: -1rem; margin-right: -1rem; ?
    J'ai voulu mettre une grid à l'intérieur d'un div qui avait un padding, et la grid dépassait de la div impunément ... J'ai mis margin:0 sur la grid et pouf plus de problème.

    Pareillement, pourquoi mettre un padding sur les .container ?
    J'ai voulu mettre un container au milieu de page, mais quand je passe en vue mobile, le padding fait qu'il y a des barres sur le côté qui n'ont pas grand intérêt. J'ai fixé padding:0 sur le container et en vue mobile les barres disparraissent.

    Ces margin et padding avaient-elles un but de compatibilité ? Pour savoir si j'ai cassé quelque chose en les forçant.

    Merci
  • JosJos Membres
    Bonjour,

    Les margin et les paddings dans .grid et .container servent au bon fonctionnement de ceux-ci. Normalement, et d'après pas mal de tests que j'ai fait, l'ensemble fonctionne bien. Pour être franc, je n'ai pas été le seul a utiliser ce genre de méthode (ex Bootstrap).

    Si tu as un bug, cela doit provenir de la div que tu as créé. Si tu veux faire un thème qui fonctionne plutôt bien, et pour éviter que tu rencontre des bugs, je te conseille d'utiliser au maximum les éléments disponibles sur le Framework.
  • ScithScith Membres
    août 2015 modifié
    J'ai aussi des soucis avec les paddings (chez moi ceux sur le .col).
    Ca m'empêche par exemple de faire des bannières colorées qui prennent toute la largeur (j'ai un padding qui se rajoute ...)

    Et pareil qu'en haut, le margin sur les .grid rajoute un scroll horizontal. Et ce même si je place un div grid juste sous le body.
    Serait-ce possible qu'un div à l'intérieur de la grid cause le scroll ? En tout cas quand je reset le margin à 0 sur le grid le problème s'en va...

    Autre soucis : la frame responsive semble paramétrée pour une résolution 16:9. Mon écran est 25:9 et si je mets une frame sur toute la hauteur de la page, j'ai un scroll (si je règle le padding-bottom sur 36% qui correspond à ma résolution ça fonctionne). N'y aurait-il pas d'autre solution que le padding-bottom par ratio pour rendre ceci responsive ?

    Sinon le truc qui serait utile pour moi ce serait un helper qui permet la hauteur de 100%. Je me casse toujours la tête en CSS là-dessus :(

    Merci
  • JosJos Membres
    Bonjour,

    Je ne rencontre pas tous les soucis que tu me décris.

    Pour faire une bannière, tu peux utiliser un .container.

    Pour la frame Responsive, oui c'est réglé pour du 16/9. Je vais réfléchir pour rendre ça plus adaptatif.
  • ScithScith Membres
    Hm du coup ça doit être un soucis avec le reste de mon CSS, je vais investiguer merci :)
  • JosJos Membres
    Si ton site est en ligne je pourrais peut-être t'aider.
  • ScithScith Membres
    décembre 2015 modifié
    Merci, désolé du temps de réponse ... Pas de nouvelle bonnes nouvelles comme on dit :) Le soucis venait du fait que j'avais un peu trop bidouillé mon CSS. Tout fonctionne maintenant.

    Nouveau soucis par contre sur gallery : si les blocs ont tous la même hauteur, pas de soucis. Mais quand les hauteurs de blocs dans gallery sont différents, ça devient rapidement le bazaar (avec des trous par-ci par-là).

    Je pourrais soit :
    - Mettre tous les blocs de même hauteur (mais ça m'arrange pas trop)
    - Ajuster la hauteur des autres blocs de la ligne au premier (mais il faudrait du javascript je pense ?)
    - Ou faire un clear:left; au premier bloc de chaque ligne

    Du coup voici mon "fix" pour la 3e solution :
    @media (max-width: 767px) {
    	.gallery.sml-12 li:nth-child(1n+1) {clear: left;}
    	.gallery.sml-6 li:nth-child(2n+1) {clear: left;}
    	.gallery.sml-4 li:nth-child(3n+1) {clear: left;}
    	.gallery.sml-3 li:nth-child(4n+1) {clear: left;}
    	.gallery.sml-2 li:nth-child(6n+1) {clear: left;}
    	.gallery.sml-1 li:nth-child(12n+1) {clear: left;}
    }
    @media (min-width: 768px) {
    	@media (max-width: 1024px) {
    		.gallery.med-12 li:nth-child(1n+1) {clear: left;}
    		.gallery.med-6 li:nth-child(2n+1) {clear: left;}
    		.gallery.med-4 li:nth-child(3n+1) {clear: left;}
    		.gallery.med-3 li:nth-child(4n+1) {clear: left;}
    		.gallery.med-2 li:nth-child(6n+1) {clear: left;}
    		.gallery.med-1 li:nth-child(12n+1) {clear: left;}
    	}
    	@media (min-width: 1024px) {
    		.gallery.lrg-12 li:nth-child(1n+1) {clear: left;}
    		.gallery.lrg-6 li:nth-child(2n+1) {clear: left;}
    		.gallery.lrg-4 li:nth-child(3n+1) {clear: left;}
    		.gallery.lrg-3 li:nth-child(4n+1) {clear: left;}
    		.gallery.lrg-2 li:nth-child(6n+1) {clear: left;}
    		.gallery.lrg-1 li:nth-child(12n+1) {clear: left;}
    	}
    }
    
  • JosJos Membres
    Bonjour,

    Avec un peu de retard (un peu surchargé ces derniers temps), je te remercie piur cette remontée. Je regarderai çà dés que j'aurais un moment.
  • SudwebdesignSudwebdesign Membres
    octobre 2018 modifié
    Salut @ tout(e)s

    J'ai fait une petite MAJ qui corrige le menu de l'admin qui [del]est[/del] était toujours ouvert sur les vieux navi android (4.x) ainsi que les classe show (+sml/med/lrg) pour les éléments inline.

    C'est ici sur github : https://github.com/sudwebdesign/PluCSS.
    Ou vous pouvez voir la demande de fusion ici : https://github.com/pluxml/PluCSS/pull/11.

    Notre temps est la seule monnaie vraie ;)

    Site - Dépôt - MyShop

  • :) Super! Merci @Sudwebdesign.
Connectez-vous ou Inscrivez-vous pour répondre.