[PLUGIN] Gutuma pour Pluxml : module de gestion de newsletters

1356711

Réponses

  • Cool Jerry !
    Je testerai sous peu ! :)
  • Bonjour à tous.

    Je viens d'installer GUTUMA avec douleur mais succès, mais je dois taper chaque commande dans la barre d'adresse. Y-a-t'il un menu qui est cessé apparaître quelque part ?

    Merci pour vos réponses.
  • Arno_Strasbourg a écrit:
    (...)avec douleur mais succès(...)


    Tu peux être plus précis s'il te plait ?


    Tu n'as pas à entrer les url dans la barre d'adresse. Si tu as placé le dossier gutuma dans le dossier plugins de pluxml, le plugin gutuma doit s'afficher dans la liste des plugins de l'administration de pluxml (parametres -> plugins).


    Il faut ensuite l'activer selon la procédure habituelle de pluxml.
    Une fois que c'est fait, un lien Gutuma apparait dans la colonne de gauche de l'administration.


    Point important, il faut être connecté avec le compte du premier utilisateur pluxml (qui est normalement l'administrateur général du site) pour finaliser l'activation.


    Seuls les administrateurs et les gestionnaires peuvent utiliser le module par la suite si leurs comptes sont activés par l'administrateur principal (celui qui a l'index 001 dans pluxml).
  • Ah désolé, mon archive est pourrie. Je vais la mettre à jour pour que tout soit dans le même dossier. Encore toutes mes excuses.
  • Ah, je me disais bien. L'archive que j'ai téléchargé ne correspondait en rien à ce que j'avais l'habitude de voir...
  • Bon, mauvaise nouvelle. J'ai une erreur 502 en production et pas en local. Donc mon plugin ne fonctionne pas.
    Je vais creuser un peu plus pour essayer de voir d'où vient l'erreur. Désolé.
  • Salut Jerry,

    Chez moi ça marche. Comme j'avais bidouillé pour l'installation précédente et que j'avais quelques bugs, j'ai réinstallé le CORE. Maintenant ça roule pas mal. Je l'ai intégré au site. Il me reste à vérifier que ça fonctionne.

    Merci.
  • Voici la version 1.3 qui corrige les bugs de la 1.2. Encore toutes mes excuses. J'avais laissé trainé des morceaux de code inadaptés.
  • Effectivement, j'ai noté quelques petits bugs. Je l'installe et essaye.
    Merci.
  • Ca y est . Ca marche nickel. J'avais noté une modification de la page de connection admin (en anglais) et un problème avec la page des réglages.
    Tout est résolu.
    Merci pour le travail Jerry.
  • Si, apparemment il y a encore un petit problème. Le lien n'apparaît plus sur le site. Est-ce que c'est chez moi ?
  • Qu'entends-tu par "le lien n'apparait plus sur le site" ?

    Je pense aue tu parles du lien dans la partie publique qui permet aux utilisateurs de s'abonner à la newsletter.

    J'ai en effet le même problème. Je vais essayer de corriger ça.
  • Dans le fichier /plugins/gutuma/news/inc/__plxml.php, ligne 20, remplacer :
    define('PLX_ROOT', '../../../');
    
    Par
    define('PLX_ROOT', $_SERVER['DOCUMENT_ROOT'].substr($_SERVER['SCRIPT_NAME'],0,strpos($_SERVER['SCRIPT_NAME'], 'plugins')));
    

    Ça devrait marcher.

    Je mets l'archive à jour de ce pas.
  • Arno_StrasbourgArno_Strasbourg Membres
    octobre 2012 modifié
    Yes, merci Jerry. Ça marche.

    Bonne soirée.
  • Bonjour Jerry,

    Juste un petit bug à signaler. Sur la page de connexion admin, depuis l'installation de gutuma, les textes ont disparus au profit de leur tag je pense : L_AUTH_LOGIN_FIELD : et L_AUTH_PASSWORD_FIELD :

    Je ne suis pas assez calé pour résoudre ça.

    Merci.
  • De quel page de connexion tu parles ? Celle de pluxml ?
  • Bonsoir Jerry & un grand merci pour ce délicieux plugin Gutuma.

    Je suis face à un plantage que je ne m'explique pas et qui persiste après un second téléchargement :

    l'install du plugin se passe sans problème, les répertoires sont bien là où ils devraient, j'ai fait et vérifié les chngmod, il y a bien, après activation du plugin gutuma dans la colonne de gauche et les messages attendus dans la colonne centrale, sauf que quand je clique sur "installer le module" (de l'utilisateur 01), patatras :

    "Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, postmaster@autaut.fr and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log."

    Dans le log je ne vois rien et le phénomène persiste quand tous les autres plugins sont désactivés.

    La seule chose que j'observe c'est l'absence d'un fichier config.php (mentioné dans l'aide) dans news/inc...

    Une idée de ce qui peut provoquer ce plantage ?
  • Jerry WhamJerry Wham Membres
    novembre 2012 modifié
    Il faut que les dossiers /inc et /temp soient disponibles en écriture. Vérifie également que le fichier install.php soit bien présent dans le dossier racine (plugins/gutuma/news) avant de cliquer sur "installer le module".


    Sinon, il faudrait plus de précision sur l'erreur générée (apache.log et php.log). Je n'ai pas eu cette erreur.


    As-tu un lien à me fournir pour que je puisse vérifier ? (peut-être par mail ?)
  • lbmhlbmh Membres
    novembre 2012 modifié
    Bravo, Jerry, tu as eu LA bonne idée : en fait /temp n'avait tout simplement pas été créé....

    Bug système, ou de dézippage, ou autre ???

    Un dézippage à neuf, un chmod et Gutuma marche nickel !

    Thanks again.

    LB
  • Je vais ajouter ce cas dans l'aide pour que tout le monde en profite.
  • Bonjour,

    Il reste juste un tout petit problème.
    Depuis l'installation de GUTAMA, j'ai la fenêtre de connexion administrateur en anglais, ou plus exactement, ce sont les labels qui sont affichés : L_AUTH_LOGIN_FIELD :L_AUTH_PASSWORD_FIELD : L_BACK_TO_SITE

    Que peut-on faire ?
    Merci.
  • Si tu désactive Gutuma, sans le désinstaller, est-ce que le problème persiste?
  • Oui Jerry, le problème persiste à la désactivation de Gutuma.
  • Donc je ne pense pas que cela vienne de mon plugin.

    Essaie de désactiver tous tes plugins, puis de vérifier si le problème est toujours là.
    Si le panneau d'admin redevient normal, c'est qu'un plugin est en cause. Sinon, c'est que quelque chose ne va pas dans ton install. Vérifie également les droits des dossiers (panneau admin, informations).

    Si le problème n'est plus là quand tous les plugins sont désactivés, c'est qu'un plugin fout le bordel. Réactivent les un à un en te déloguant à chaque fois et vois lequel est en cause.

    Si rien de tout cela fonctionne, sort le dossier gutuma du dossier plugins (met le en dehors du dossier www pour être sûr) et dis moi ce qu'il en est.

    Si les symptômes persistent, [del]consultez votre médecin[/del], supprime le carrément (en conservant dans un coin le dossier list pour ne pas perdre tes données).
  • Alors, j'ai désactivé tous les plugins - Déconnecté et reconnecté - Mêmes symptômes !
    J'ai carrément effacé le dossier GUTUMA (après sauvegarde) - Déconnecté, reconnecter - La page de connexion admin est redevenue normale. J'ai refait le test 2 fois pour être sûr. Lorsque le dossier GUTUMA est présent dans les plugins, le problème réapparaît.
    J'ai pu également remarquer que lorsque je clique sur deconnexion, pluxml revient à la page de connexion admin qui à ce moment là est normale. Donc ça vient bien de Gutuma. Ce problème est apparu après son installation d'ailleurs...
  • Je ne comprends pas, je n'ai pas le problème chez moi sur les différents serveurs testés.

    Quelle sont les versions du plugin et celle de pluxml ?
  • Arno_StrasbourgArno_Strasbourg Membres
    novembre 2012 modifié
    Alors PluXml c'est la version 5.1.6 et Gutuma c'est la tienne 1.6 Béta PHP version 5.2.17.
    Je vais essayer de tout réinstaller. Sinon l'adresse est

    http://www.teoufouwak.perozeni.com/core/admin/auth.php?p=/core/admin/
  • Incroyable !! Dés que j'ai décompressé le dossier "plugin-gutuma-for-pluxml-v1.3.zip" dans le dossier plugins, le problème est revenu...
    Je crois que je vais laisser comme ça. Après tout c'est pas bien grave...!!
  • Bonjour
    Vérifie les droits sur le dossier et fichiers de gutuma et du plugin.

    Consultant PluXml

    Ancien responsable du projet

  • Tu as fait quelque chose de particulier car quand je vais sur l'adresse indiquée, tout s'affiche correctement ???
Connectez-vous ou Inscrivez-vous pour répondre.