[PLUGIN] Gutuma pour Pluxml : module de gestion de newsletters

13468911

Réponses

  • Je viens de regarder et je ne parviens pas à reproduire le bug. Je t'ai envoyé un mail...
  • En effet, ça merde grave...
    Mais je me pose une question : où as-tu chargé ta version de pluxml ? Est-ce la version latest ou la version master (comment s'appelle le zip) ?
  • Je ne sais pas s'il n'y a pas un souci avec le plugin multilangue. Et un problème de droits sur les dossiers.
    En regardant tes sources, il faudrait virer le fichier gutumaindex.html dans le dossier data et le fichier GU_CONFIG_LANG dans le dossier plugins/gutuma/news/lang
  • Bon je crois que je vais recommencer une install propre histoire d'être sur.
    Merci pour ton temps. Je te tiens au courant.
  • @JerryWham
    Hello,
    Bon j'ai juste ré-installé pluxml (latest) et gutuma (master donc sur le git je suppose) et j'ai toujours ce bug lorsque je passe dans les réglages mon compte passe de admin à rédac.
    Je pense du coup à un problème d'hébergement si je suis le seul à avoir le problème.
    Je vais faire marabouter OVH....
  • Ce n'est pas uniquement en cliquant sur réglages. Dès que tu passes de pluxml à gutuma, ton statut change. Je n'ai pas pu le reproduire sur mes différents hébergements mais uniquement sur le tien. Il serait bien d'avoir accès partiellement au log php pour voir si des erreurs sortent (et lesquelles).
  • J'ai également eu ça hier lorsque j'ai installé gutuma sur le site de mon asso qui est hébergé chez Ovh.
    Mais je n'y avais pas trop apporté attention.
    Il faudra que j'essaie sur sur mon site perso qui est hébergé chez Nuxit
  • Bon, ça viendrait alors de chez OVH ? Je n'ai pas d'hébergement chez eux. Si quelqu'un pouvait m'aider un peu pour savoir ce qui se passe...
  • Un passage de PHP 5.2.17 à 5.4.6 par le Htaccess semble résoudre les problèmes sur OVH (mutualisé pour moi) je continue à tester.
  • Ah ! Ça se précise...
  • Bonjour

    A-priori ça fonctionne.
    Petite question lorsque je suis en rédaction d'une newsletter et que je veux insérer une image il faut que je saisisse l'url de celle-ci ( ce qui est peut pratique), il me rajoute alors l'adresse voulue par le olugin.
    N'y aurait -il pas une possibilité comme pour les articles d'avoir une sorte de file manager?
    Pareil dans le dossier thème, il y a deux themes defaut et gutuma, c'est bien pour l'administration du plugin? et non pas pour la newsletter envoyé?

    Cordialement
  • Hello,

    M'initiant à PluXml depuis quelques semaines, il n'y a plus qu'une newsletter qui manque à mon bonheur :)
    J'ai téléchargé le plugin Gutama dans mon répertoire plugins mais étonnamment je ne le trouve pas listé dans les plugins inactifs.

    J'utilise Pluxml 5.2 et la version de gutama liée sur le premier message de cette discussion. Il s'agit de la version 1.6 d'après le fichier xml :
    [== XML ==]
    <?xml version="1.0" encoding="UTF-8"?>
    <document>
      <title><![CDATA[Gutuma]]></title>
      <author><![CDATA[Cyril MAGUIRE]]></author>
      <version>1.6</version>
      <date>01/10/2013</date>
      <site>http://www.ecyseo.net</site>
      <description><![CDATA[Intégration à Pluxml de l'application Gutuma permettant de gérer des newsletters]]></description>
    </document>
    

    J'ajoute que le chmod de l'ensemble du répertoire est : 705 comme les autres plugins déjà installés.

    Une idée du pourquoi du comment ?

    Fab
  • Vérifie que le dossier s'appelle gutuma et non gutuma-master. Si c'est le cas, c'est github qui ajoute ce suffixe systématiquement. Il faut le supprimer.
  • Ok merci c'était bien ça! :)

    Par contre j'arrive sur un nouveau bug au moment de lancer l'installation (page : .../plugins/gutuma/news/install.php) :
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    ...


    Je suis chez OVH. J'ai vu dans les précédents messages qu'il pouvait poser problème.
    J'ai précisé la version 5.4.6 dans le htaccess comme indiqué précédemment mais sans plus de succès.

    Un autre détail qui n'a rien à voir avec le problème mais qui peut un peu perturber, l'infobulle apparaissant sur l'écran précédent ne donne pas le bon chemin des dossiers dont il faut changer les droits. Voir la capture d'écran.
  • StéphaneStéphane Member, PluXml Former Project Manager
    Chez ovh j'ai vu qu'il faut obligatoirment mettre les droits 644 sur les fichiers et 705 sur les dossiers. J'ai eu le cas d'une erreur "Internal Server Error". Après rectification des droits tout est revenu normal

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Ok merci j'ai maintenant réussi l'installation.

    Par contre, de retour sur la page [em]"core/admin/plugin.php?p=gutuma"[/em], je vois un message d'erreur :
    Parse error: syntax error, unexpected 'Lab' (T_STRING) in /homez.330/ecrivezm/www/fablab/plugins/gutuma/admin.php(33) : eval()'d code on line 3

    En ligne 33 de admin.php, je trouve :
    [== PHP ==]
    eval(base64_decode(substr(file_get_contents($plxPlugin->listsDir.'/inc/config.php'),9,-5)));
    

    Or il n'y a pas de [em]config.php[/em] dans le répertoire [em]news/inc/[/em].

    Et lorsque je clique sur le bouton "Accéder au module de newsletter", je retourne sur la page d'installation qui a logiquement été supprimée donc j'obtiens un message d'erreur.
    Il y a peut-être quand même eu une erreur lors de l'installation ?

    Fab
  • Le fichier config doit se trouver normalement dans le dossier data/gutuma/inc/ afin de faciliter les mises à jour et les sauvegardes. Vérifie qu'il y soit.
  • Oui je confirme qu'il y a bien un fichier config dans le répertoire [em]data/gutuma/inc/[/em]
  • Peux-tu m'envoyer par mail le fichier config s'il te plait pour voir ce qui bugue ?
  • Salut Jerry,

    Juste une petite question est il possible de modifier le mail et le nom de l'expéditeur des newsletters (pas forcément l'admin du site) ?
    Le config est crypté est-ce qu'il y a moyen de décrypter et recrypter ?
    Merci d'avance
    et encore bravo pour ce plugin que l'on utilise tout le temps :)
    A+
  • FrancisFrancis Member
    novembre 2013 modifié
    Moi aussi, ça m'intéresserait de pouvoir lire et modifier ces données (listes, expéditeurs) qui sont cryptées.
    Je ne vois pas trop l'intérêt qu'elles soient cryptées, d'ailleurs.
  • Jerry WhamJerry Wham Member
    novembre 2013 modifié
    Je les ai cryptées pour qu'elles ne soient pas facilement modifiables. C'est pour faire chier ceux qui voudraient faire chier ]:D .

    Sinon, pour décrypter les données, voici les étapes à suivre, strictement dans cet ordre (je ne serai pas responsable d'une fausse manip) :

    ATTENTION DE REALISER LA MANIP DIRECTEMENT DEPUIS LE SERVEUR SUR LEQUEL EST INSTALLE LE PLUGIN SINON LA REDIRECTION SERA CASSEE ET LA PROCEDURE RISQUE ECHOUER. A REALISER A VOS RISQUES ET PERILS.

    1 ) Sauvegarder vos données (dossier data/gutuma et dossier plugins/gutuma)
    2 ) Sauvegarder vos données (dossier data/gutuma et dossier plugins/gutuma) on ne le dira jamais assez.
    3 ) Ouvrir le fichier plugins/gutuma/inc/setting.php et ajouter à la ligne 27, dans la méthode get_version(), le code suivant (s'il n'y est pas déjà) :
    self::reload();
    
    4) Commenter le code de la ligne 233 de ce même fichier, de la façon suivante :
    /* file_put_contents(GUTUMA_CONFIG_FILE,"<?php /*\n".base64_encode($f)."\n*/  /*?>");*/
    
    5 ) Décommenter le code de la ligne 235 pour obtenir :
    file_put_contents(GUTUMA_CONFIG_FILE,"<?php \n".$f."\n?>");
    
    6 ) Enregistrer sans fermer le fichier.
    7 ) Se rendre dans le panneau de config de pluxml et cliquer sur gutuma dans la colonne de gauche, puis sur "accéder au module de newsletter", puis se rendre à la section réglages.
    8 ) Cliquer sur "Enregister" en bas de page. Un message de confirmation doit vous dire que l'enregistrement s'est bien déroulé.
    9 ) Le fichier de config est alors décrypté mais ce n'est pas fini. Pour que gutuma continue de fonctionner, rendez-vous à la ligne 123 du fichier setting.php.
    10) Commenter la ligne 123 et décommenter la ligne 125
    11) Commenter la ligne 186 et décommenter la ligne 188
    12) Enregistrer le fichier
    13) Se rendre à nouveau dans le panneau de config de pluxml et cliquer sur gutuma puis accéder au module. Le formulaire de login devrait vous demander de vous connecter et tout devrait fonctionner.

    Pour crypter à nouveau les données, procéder dans le même ordre mais en commentant les lignes décommentées et en décommentant les lignes commentées. Le self::reload(); pourra être conservé.
    Pour la ligne 233, le code décommenté doit être :
    file_put_contents(GUTUMA_CONFIG_FILE,"<?php /*\n".base64_encode($f)."\n*/  ?>");
    
  • Merci Jerry, c'est sympa.
    Pour la prochaine version, ce serait intéressant d'avoir ça en option, avec une case à cocher "cryptage des données" dans la config du plugin, qu'en penses-tu ?
  • De rien. Pour l'option, faut voir...
  • bonjour, qq'un sait comment Fab56 à résolu son problème ?
  • Lequel problème car il en a eu plusieurs. Et si tu relis les différents posts, les solutions sont dedans... :P
  • paysan hardi a écrit:
    bonjour, qq'un sait comment Fab56 à résolu son problème ?

    Mon installation continuait à bugger.
    Mais cela ne fait rien, je n'ai pas encore fait mon choix mais j'utiliserai un autre outil de newsletter indépendant de PluXml.
    C'était surtout pour le tester puisqu'un un plugin existait.
  • Si ça continue de bugguer, faut me le dire. Je ne pourrai pas corriger si je ne suis pas informé des problèmes rencontrés... :(
  • Amha... comme tu me l'avais demandé, je t'avais envoyé mon fichier de config en MP et cela en est resté là.

    C'est peut-être un problème spécifique à Gautama chez OVH. Je n'ai pas essayé de l'installer indépendamment de PluXml.
  • J'ai un petit problème ... :|

    Le fichier config ne se créé pas ... :(

    Le pluggin est bien installé, j'ai bien le lien Gutuma tout en bas de mon menu sur mon administration, et quand je clique dessus, ça m'amène bien à la page d'identification, mais quand je clique sur "accéder au module de newsletter", ça m'affiche une page blanche avec cette adresse : plugins/gutuma/news/login.php?action=plxlogin&ref=compose.php
    Alors je modifie directement l'adresse en plugins/gutuma/news/login.php et là, tout apparait bien sans m'être identifié ! :o

    J'ai fais des test en envoyant une newsletter, et ça fonctionne très bien.

    Mais il ne faut pas que je clique sur le lien "Gutuma" dans mon admin, sinon je reviens à la page d'identification et donc après avoir cliqué sur "accéder au module de newsletter" je reviens sur la page blanche ... Il faut donc refaire ma petite modif et j'y arrive enfin ...

    Ca fonctionne, mais ce n'est pas très pratique ...

    Une idée du problème ?

    Merci ! ;)
Connectez-vous ou Inscrivez-vous pour répondre.