[plugin] CKEditor: editeur wysiwyg

18911131418

Réponses

  • chrisschriss Member
    décembre 2014 modifié
    memento a écrit:
    Bonsoir,
    @chriss : il faut que tu rajoutes le code ci-dessous dans le fichier de configuration config.js de CKEditor
    [== JavaScript ==]
        config.allowedContent = {
            $1: {
                // Use the ability to specify elements as an object.
                elements: CKEDITOR.dtd,
                attributes: true,
                styles: true,
                classes: true
            }
        };
    
    Cordialement

    Merci, je vais essayer cela...

    Et Joyeux Noel

    EDIT: désolé mais ne fonctionne pas....Je l'avais déjà essayé :(
    Mais quand même Joyeuses fêtes :)
  • Bonjour,
    PPmarcel a écrit:
    Je rencontre un bug déjà constaté dans la version précédente : lorsque j'inclue des images et que je sauvegarde l'article, cela ajoute un slash au début de l'URL de l'image.

    On passe de "/data/images/...jpg" à "//data/images/...jpg".

    Et je n'ai ce problème que dans le chapô, mais pas dans le contenu.

    ne serait pas ce problème, enfin cela y ressemble
    https://github.com/pluxml/PluXml/commit/5277ce54f2284061619d0783ad2c27f952a1be2f
  • PPmarcelPPmarcel Member
    décembre 2014 modifié
    Ok, je vais préparer un environnement avec un accès qui va bien dans les jours qui viennent.

    Merci.
  • A-priori le plugin fonctionne avec la version de développement de pluxml.
  • Bonjour tous,

    Actuellement sur le développement d'un module Ecommerce, je suis confronté à un bug plutôt gênant venant de CKEditor.
    Une fois CKEditor activer dans mes plugins, il réécrit les adresses mail en eval() et fait foiré mes routines de contrôle de formulaire JS. une fois CKEditor désactiver je n'ai plus le bug en question.
    Pourquoi une telle réécriture d'adresse mail ?

    PS: j'ai rajouter pour des besoins personnel un petit plugin à CKEditor permettant d'afficher un spoiler dispo ici.

    ++
  • StéphaneStéphane Member, PluXml Former Project Manager
    @CKDevelop. Utilises-tu la dernière version du plugin ckeditor ?
    CKEditor
    version 4.4.6 (17/12/2014)
    CKEditor 4.4.6
    

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Stéphane a écrit:
    @CKDevelop. Utilises-tu la dernière version du plugin ckeditor ?
    CKEditor
    version 4.4.6 (17/12/2014)
    CKEditor 4.4.6
    
    ourch :-/ effectivement je me trimballe une vielle version de CKEditor
    [== Indéfini ==]
    CKEditor - Version 1.5 (02/08/2013)
    CKEditor 3.6.4 + KCFinder 2.51
    

    je test la dernière version dans la journée, merci

    ++
  • re,

    petit retour pour vous signaler que le bug est effectif que sur l'ancienne version.
    [== Indéfini ==]
    CKEditor - Version 1.5 (02/08/2013)
    CKEditor 3.6.4 + KCFinder 2.51
    

    le passage à la nouvelle version à réglé le souci.
    Merci Stéphane

    ++
  • stephane donne la démarche pour intégrer un plugin dans ckeditor ICI
    malgré cela impossible pour moi d'installer quoi que ce soit exemple pour colordialog cette ligne de code:
    config.extraPlugins = 'colordialog';
    que je colle dans configuration ckeditor dans la ligne "extraPlugins"
    rien ne s'active..et j'ai perdu le visuel de ckeditor dans l'article..
    il manque quoi ???
  • StéphaneStéphane Member, PluXml Former Project Manager

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • j'ai préféré remettre l'ancienne version
    il y'a certains soucis quand on ajoute un code youtube ou bandcamp avec un style, le style est supprimé
  • StéphaneStéphane Member, PluXml Former Project Manager
    @MrFoufou: le code youtube ne doit pas être stylé. s'il doit être mis en forme c'est à faire par css. au pire il y a des plugins pour ckeditor qui gère les videos youtube.

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Bonjour,

    Est-il possible de paramétrer le plugin pour avoir une barre d'outils différente suivant le type d'utilisateurs?
  • StéphaneStéphane Member, PluXml Former Project Manager
    @cpalo: le plugin en l'état ne permet pas de le faire sans mettre les mains de le code. Mais techniquement c'est faisable oui

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Bonjour Stéphane,

    Je viens de t'envoyer par email les identifiants que tu m'avais demandé. Il n'y a pas d'urgence.

    Merci.
  • StéphaneStéphane Member, PluXml Former Project Manager
    ## Version 4.4.6.1 (27/01/2015) ##
    BUG: pas d'affichage des images dans le chapo

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • janvier 2015 modifié
    Juste un petit mot pour indiquer qu'il n'y a plus de problèmes avec l'anti spam avec cette version du plugin (contrairement à l'ancienne version).

    J'ai juste rajouter le plugin smiley pour retrouver les smileys qui étaient dans mes précédents posts (et ceux qui seront dans mes futurs) : tout roule ! ;-)
  • Bonjour,

    Je viens de faire la maj du plugin sur la version en développement de Pluxml.
    Alors qu'auparavant il n'y avait pas de problème, là l'éditeur ne se lance pas. On se retrouve avec une page blanche sans les zones ni les barres d'édition.

    Cordialement
  • StéphaneStéphane Member, PluXml Former Project Manager
    @cpalo: regarde les droits sur le dossier de ckeditor, s'ils n'ont pas sautés

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • J'ai le meme problème sur un site avec la version 5.3.1 de Pluxml.
    J'ai testé en local.
    Je vais tester sur le serveur d'hébergement.
  • StéphaneStéphane Member, PluXml Former Project Manager
    @cpalo: as-tu fait la mise à jour en passant par plxMyPluginDownloader ?

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Sur le serveur d'hébergement ( droits 777) j'ai le même problème avec pour seul plugin d'installé, ckeditor
  • La mise à jour je l'ai fait par copier-coller et non par le plugin.
    Mais sur le serveur, c'est un pluxml "neuf" avec la version "neuve" de ckeditor que j'ai téléchargés par ftp
  • StéphaneStéphane Member, PluXml Former Project Manager
    @cpalo: j'ai vérifié les sources de ckeditor. ça me semble ok, pas d'erreurs qui feraient planter l’éditeur. Chez moi il se charge bien. Essaye de refaire une installation manuellement de ckeditor en téléchargeant le .zip

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Je ne peux pas télécharger à nouveau le zip car en suivant le lien ( cf ton site) j'obtiens une erreur 500
  • StéphaneStéphane Member, PluXml Former Project Manager
    effectivement tous mes sites chez 1&1 affiche une erreur 500. Est-ce que je suis le seul ?

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Si j'installe la version initiale, aucun problème.
  • StéphaneStéphane Member, PluXml Former Project Manager
    La page de téléchargement des plugins est de nouveau dispo sur pluxopolis.net
    Sinon tu peux directement récupérer le plugin ici: https://github.com/Pluxopolis/ckeditor/releases

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Sois rassuré...
    en téléchargeant à nouveau le zip...
    et en réinstallant de façon "propre", cela fonctionne.

    Merci
  • Salut,

    J'ai un problème quand je travaille sur une page avec CKeditor.

    J'aimerais bien mettre les documents d'un côté et les images de l'autre mais Roxyfileman ne m'affiche pas le dossier Documents

    150206064706671986.jpg

    J'utilise les dernières versions (qui datent de 2 jours) des plugins et de PluxML.

    Pouvez-vous m'aidez ?
Connectez-vous ou Inscrivez-vous pour répondre.