[plugin] CKEditor: editeur wysiwyg

11213151718

Réponses

  • si tu es sur Firefox, appuie sur F12, ensuite recharge la page de choix de fichiers
    après que le message apparait va dans "Réseau", clique sur "dirtree.php" et montre nous ce qu'il y a dans l'onglet "réponse"
  • @Ghune,

    Chez Free, il y a 2 versions de PHP.
    Ca dit quoi dans le menu d'administration en cliquant sur "Paramètres/informations", puis "version de php" ?

    A++
  • Il n'y a rien. Je me suis peut-être mal débrouillé mais rien !
    Les seules infos sont ici : http://i.imgur.com/tMmzH5V.png
  • mathieumathieu Member
    décembre 2015 modifié
    oui c'est ce que je voulais voir. mais le retour de dirtree.php est à 0 donc ça ne m'aide pas à voir ce qu'il se passe

    essaye d'aller à l'URL pluxmltest/plugins/ckeditor/fileman/php/dirtree.php?type=image une fois connecté à l'admin et montre nous si tu as un résultat
  • GhuneGhune Member
    décembre 2015 modifié
    Rien. La page est blanche. Il n'y a pas d'erreur, mais la page est vide.

    Edit: je crois que je vais installer la version précédente, il paraît qu'elle fonctionne avec la dernière version de Pluxml...
  • Pour mieux voir ce qu'il se passe j'aurai besoin des codes FTP.
    Mais je comprends qu'on n'aime pas donner les codes d'accès à son site donc attends peut-être pour voir si quelqu'un a une autre idée pour régler ce problème et je resterai là en dernière solution si rien d'autre ne fonctionne
  • mathieu a écrit:
    Pour mieux voir ce qu'il se passe j'aurai besoin des codes FTP.
    Mais je comprends qu'on n'aime pas donner les codes d'accès à son site donc attends peut-être pour voir si quelqu'un a une autre idée pour régler ce problème et je resterai là en dernière solution si rien d'autre ne fonctionne
    Envoyé par email !
  • bon et bien j'ai trouvé le problème mais pas la solution.
    chez free.fr il n'y a pas la bibliothèque "mbstring" et donc on ne peux pas utiliser toutes les fonction mb_*

    ces fonctions sont utilisées de tous les cotés dans le répertoire "fileman" donc pour pouvoir utiliser cela chez free.fr, ça demande un gros travail de remplacer toutes les fonctions
  • Merci d'avoir essayé !

    Tant pis, ća veut dire que la version précédente est à recommander, j'imagine...

    Bonne nuit !
  • Bonjour,

    J'ai un petit "soucis" avec l'ajout de CKEditor ; je m'explique ; depuis que je l'ai ajouté je me retrouve avec les anciens outils de mises en forme de PluXML + CKEditor ; le problème étant que CKEditor occupe alors l'angle supérieur droit de l'édition de mes articles et pages statiques ...

    Je suppose qu'il y a une méthode simple de désactiver/cacher l'outil de mise en forme par défaut de PluXML alors avant de faire une erreur ruinant tout mon travail je me permet de venir poster ici me disant que ce qui m'embête à dores-et-déjà dû embêter d'autres utilisateurs qui depuis le temps ont également peut-être trouver la méthode ?

    Je suis novice sur PluXML que je découvre depuis peu mais l'édition dans le code je devrais pouvoir y arriver puisque c'est du PHP en grande partie langage qui m'est assez familier pour éviter de faire n'importe quoi ;)

    Dans l'attente de vous lire prochainement,

    bien à vous,
    Anakore.
  • StéphaneStéphane Member, PluXml Former Project Manager
    Bonjour Anakore

    Quels sont les "anciens outils" dont tu parles ?
    As-tu désactivé les plugins que tu n'aurais plus besoin. ça rentre surement en conflit avec ckeditor.

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • AnakoreAnakore Member
    février 2016 modifié
    [del]En fait je n'avais aucun plugin autre que CKEditor ... [/del]

    En effet Stéphane vous aviez raison ! désolé pour cette intrusion ...

    > Mon problème est donc résolu désormais ; en effet c'est CKEditor qui ne s’imbriquait pas en dessous de "plxToolbar - Version 1.3 (15/07/2015)" ...
    Donc en fait c'est soit l'un soit l'autre ; car même si j'édite souvent mes pages & articles en mode "sources" de temps en temps la barre d'outils justifie son utilité ^^
  • Salut Salut,

    Petit question : j'ai un petit souci avec l'explorateur de serveur.
    Quand je clique dessus, je ne retrouve pas le contenu du répertoire "medias".

    Quelqu’un a-t-il déjà eu ce souci ?

    Merci
  • Bonjour,

    J'ai le même problème que djinlemage avec PluXml 5.5 en local avec WampServer et la dernière version de CKEditor (4.5.3).
    J'ai testé avec php 5.6, php 7, php 5.5 et php 5.4 et toujours le même problème.

    Lorsque je "télécharge" un fichier, la progression arrive à 100%, mais rien n'apparaît dans le dossier "medias" (ou "images"). Alors que j'ai mis des fichiers images dedans par ailleurs.

    Lorsque je tente de créer un nouveau répertoire depuis Roxy File Manager, il indique "Erreur lors du chargement medias" et ne crée pas de répertoire.

    Où peut-on télécharger une version précédente de CKEditor pour faire des tests ?

    Merci.
  • StéphaneStéphane Member, PluXml Former Project Manager
    Suricat a écrit:
    Où peut-on télécharger une version précédente de CKEditor pour faire des tests ?

    Merci.

    Salut

    https://github.com/Pluxopolis/ckeditor/releases

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Merci !
  • Rien à faire,

    Avec une installation 5.5 vierge et CKeditor 4.5 ou 4.4, ça ne fonctionne pas.
    Est-ce mon installation WampServer locale qui ne serait pas compatible, ou bien CKeditor n'est pas compatible avec la 5.5 en local ?
  • Bon ça ne fonctionne pas non plus avec PluXml 5.4 local.
    Quelque chose m'échappe...
  • Bonjour,

    J'ai installé le plugin CKEditor - Version 4.5.3 et je le vois bien activé dans ma page Admin.

    Mais lorsque je veux éditer une page statique, je vois :

    Édition du code source de la page statique
    Contenu :

    Mais sous le contenu, RIEN ne s'affiche, ni le contenu de la page, ni la barre CKEditor 8.(

    Puis, tout en bas, j'ai
    Visualiser la page XYZ sur le site

    Comme si le contenu ne "peut" pas s'afficher...

    J'utilise PluXML 5.3.1. Est-ce un problème de compatibilité ?

    J'ai bien tout vérifié, mais je ne vois pas ce qui cloche...

    Merci pour votre aide !
  • StéphaneStéphane Member, PluXml Former Project Manager
    Bonjour @Lau029

    va dans l'écran de configuration de ckeditor pour activer l'option qui permet d'avoir l'éditeur au niveau des pages statiques.

    nb: ne pas saisir de code php dans les pages statiques avec ckeditor. le code ne sera pas pris en compte par PluXml, car ckeditor convertit le code php en équivalent html.

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Bonjour Stéphane,

    Merci. Je l'avais pourtant bien activée tout au début...

    Suite à ton message, j'ai désactivé l'option pour les pages statiques, puis l'ai réactivée par la suite et finalement, cela fonctionne...

    Alors voilà, tout semble OK pour l'instant... Merci !
  • StéphaneStéphane Member, PluXml Former Project Manager
    ## Version 4.5.11 (09/11/2016) ##
    [+] Mise à jour ckeditor 4.5.11
    [+] Mise à jour des plugins de ckeditor
    Roxyfileman 1.4.5 http://www.roxyfileman.com/
    Justify Plugin 4.5.11 http://ckeditor.com/addon/justify (justify)
    Show Blocks 4.5.11 http://ckeditor.com/addon/showblocks (showblocks)
    oEmbed Plugin 1.1.7 http://ckeditor.com/addon/oembed (oembed)
    Widget Plugin 4.5.11 http://ckeditor.com/addon/widget (widget)
    Line Utilities 4.5.11 http://ckeditor.com/addon/lineutils (lineutils)

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Super !
    Merci Stéphane pour cet MAJ.
    C'est pour moi le meilleur éditeur :D
  • Bonjour,

    J'utilisais la version personnalisée proposée par Francis
    voir le post #356
    Comment dois-je procéder pour appliquer cette derniere mise à jour du plugin.

    Cordialement
  • cpalocpalo Member
    décembre 2016 modifié
    Bonjour,

    Pas de pb pour la mise à jour... j'ai seulement fait attention à sauvegarder auparavant sous un autre nom le fichier config.js.
    Mais du coup, en ayant été voir un peu la doc et les fichiers du plugin, et pour aussi disposer de deux barres d'outils différentes, j'ai donc créé un dossier custom (dans ckeditor/ckeditor/custom) avec mes deux fichiers basic_config.js et advanced_config.js
    Deux questions pour que cela soit pris en compte:
    - le chemin : /custom/advanced_config.js qui n'est pas correct ??
    - par quoi remplacer editor1 :content, chapo ?

    Le fichier ckeditor/ckeditor/config.js que j'ai modifié
    [== JavaScript ==]
    CKEDITOR.editorConfig = function( config ) {
    	// Define changes to default configuration here. For example:
    	// config.language = 'fr';
    	// config.uiColor = '#AADC6E';
    };
    
    /**
     * suivant la barre d'outils que je souhaite,
     * je sélectionne l'un des trois fichiers ci-dessous
     */
    
    CKEDITOR.replace( 'editor1', {
        customConfig: '/custom/advanced_config.js'
    });
    
    
    /**
    CKEDITOR.replace( 'editor1', {
        customConfig: '/custom/basic_config.js'
    });
    */
    
    /**
    CKEDITOR.replace( 'editor1', {
        customConfig: '/custom/stephane_config.js'
    });
    */
    
  • Bonjour.
    Quelques soucis avec ce plugin concernant l'insertion d'images:

    Installation en local:

    PluXml version 5.5 (encodage UTF-8)
    CKEditor - Version 4.5.11

    Version de PHP : 7.0.8
    Apache/2.4.18

    Dossier de stockage des fichiers : data/medias/


    Clic sur image -> parcourir le serveur -> Roxy file manager s'ouvre:
    J'ai dans la colonne de gauche "l'icone du repertoire medias (0)" et dans la colonne de droite : "ce dossier est vide" alors qu'il contient des images et des sous-répertoires.

    Colonne de gauche,si je clic sur "Créer un nouveau dossier, la fenêtre de saisie s'ouvre, j'entre un nom, je clic sur Créer, j'ai un message " Erreur lors du chargement medias.

    Colonne de droite, si je clic sur Ajouter un fichier, la fenêtre "Telécharger des fichiers s'ouvre -> clic sur parcourir, je selectionne une image sur mon ordi -> ouvrir -> Télécharger -> le telechargement du fichier affiche bien 100% et passe au vert, mais le fichier n'est en fait pas téléchargé dans le répertoire médias.
  • StéphaneStéphane Member, PluXml Former Project Manager
    @adjaya: Bonjour. Est-ce que le dossier data/medias/ est accessible en lecture/ecriture

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • adjayaadjaya Member
    décembre 2016 modifié
    permissions du répertoire medias:
    moi -> rwx
    groupe www-data -> rwx
    autre -> r-x

    J'ai pensé à un problème de droit, mais le plugin plxEditor wysiwyg editor par contre fonctionne correctement avec cette configuration.
  • Bonjour,
    Ce plugin a-t-il besoin d'autres plugins pour bien fonctionner ? Par exemple ceux listés au post #443 ?

    Sur un hébergement mutualisé Free, il fonctionne bien sauf pour l'insertion d'images. J'obtiens le message cité plus haut :
    E_LoadingAjax php/dirtree.php
  • StéphaneStéphane Member, PluXml Former Project Manager
    @trentanel: de mémoire, ckeditor ne fonctionne pas sur free à cause des restrictions imposées par l'hébergeur pour le fonctionnement du gestionnaire de fichier fileman (certaines fonctions php utilisées sont interdites par free)

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

Connectez-vous ou Inscrivez-vous pour répondre.