[SPXLIGHTBOX] lightbox swipebox, prettyphoto, zoombox

je-evrardje-evrard Membre
août 2015 modifié dans Plugins
spxlightbox 1.1

spx_lightbox2.jpg

Intègre 3 lightbox à votre pluxml : swipebox, prettyphoto, zoombox. Vous pouvez choisir le lightbox selon les supports.

Choix de la lightbox avec configuration :
- swipebox, prettyphoto, zoombox

lightbox activée sur sortie :
- article (oui / non)
- pages statique (oui /non)

Choix des Lightbox selon les supports :

[list=*]
[*]Téléphones (<768px)[/*]
[*]Tablets (≥768px)[/*]
[*]Desktops (≥992px)[/*]
[*]Desktops (≥1200px)[/*]
[/list]


activation de la lightbox sur des liens :
liens vers une image :
<a href="monimage.jpg">...</a>

activation de la lightbox sur des images isolées éditées dans spxtynimce (>=1.4) :
Une image :
<img src="data/image1.jpg" width="180" height="68" data-spxtynimce="true">
devient un lien lightbox :
<a href="data/images/Penguins.jpg" data-spxlighbox="true">
<img src="data/images/Penguins.jpg" alt="Penguins" width="600" height="449" data-spxtynimce="true">
</a>

activation de la lightbox sur liens videos
<a href=" >youtube</a>
<a href="


Téléchargement 1.1 ici


Historique :

version 1.0 (21/11/2014)
+ [OPT] optimisation du chargement des librairies
+ [ADD] add fresco lib

version 1.0 (11/01/2013)
+ [BUG] social link, quote...

version 0.9 (23/10/2013)
+ [BUG] fix regex pour protéger lien avec image (pas de duplication de <a>)

version 0.8 (22/10/2013)
+ [BUG] fix librairy jquery

version 0.7 (21/10/2013)
+ [BUG] instance pretty photo sans la virgule à la fin (internet explorer n'a pas aimé)
+ [BUG] change dans zoombox la detection internet exlorer pour version jquery >= 1.9 ($.browser.msie n'existe plus dans jquery >=1.9)

version 0.6 (20/10/2013)
+ sortie
«134

Réponses

  • Je ne pense pas que ce soit nécessaire de laisser le choix entre class et rel. Il vaut mieux je pense, utiliser une classe qui sera toujours valide pour le w3c.

    HS : un paramétrage, c'est masculin. On dit donc un paramétrage GLOBAL. Je sais que par les temps qui courent, on essaie de lisser les différences homme/femme et que l'orthographe ne signifie plus rien, mais je suis de la vieille école et lire ça sur le net me pique à chaque fois les yeux...
  • P3terP3ter Responsable de PluXml
    Effectivement ça existe, mais ton plugin serait plus complet et "modulable". Donc très intéressant :-)
  • je-evrardje-evrard Membre
    septembre 2013 modifié
    Dire que mon fiston est excellent en ortographe !!! :)

    Sinon si vous avez des remarques... Ne pas hésiter, c'est le moment, je suis dedans. Livraison ce week end normallement.
  • GzygGzyg Membre
    septembre 2013 modifié
    Pour avoir intégré swipebox sur un autre CMS, je valide totalement ce choix en tant que plugin pour PluXml ! :)


    à plus,

    Gzyg
  • Un peu de retard. Patience. Pas toujours facile la vie.
  • L'idéal serait que swipebox soit activé si le visiteur utilise un Smartphone/Tablette, et que prettyphoto ou zoombox soit activé sinon (pour qu'on sorte du zoom avec un seul clic en dehors du cadre).
  • Je note cette option. merci.
  • P3terP3ter Responsable de PluXml
    Suricat a écrit:
    L'idéal serait que swipebox soit activé si le visiteur utilise un Smartphone/Tablette, et que prettyphoto ou zoombox soit activé sinon
    +1 c'est une bonne idée d'option à proposer dans l'admin du plugin ;-)
  • je-evrardje-evrard Membre
    septembre 2013 modifié
    Ce sera fait dans les options.

    Je ferais un tableau d'activation des lightbox selon le media query.
  • Presque terminée...
  • Courage !
  • je-evrardje-evrard Membre
    octobre 2013 modifié
    Sortie de la version de test. :) (enfin une version)
  • je-evrardje-evrard Membre
    octobre 2013 modifié
    version 0.7 (21/10/2013)
    + [BUG] instance pretty photo sans la virgule à la fin (internet explorer n'a pas aimé)
    + [BUG] change dans zoombox la detection internet exlorer pour version jquery >= 1.9 ($.browser.msie n'existe plus dans jquery >=1.9)
  • P3terP3ter Responsable de PluXml
    Bonjour,

    Je teste ton plugin en 0.7.
    Faut-il utiliser spxtynimce pour que spxlightbox fonctionne ? Car j'utilise plxEditor et bien que le plugin ajoute les balises <a>...</a> sur les balises <img>...</img> de mes articles, la lightbox ne s'ouvre pas, et l'image s'affiche seul dans la page.
  • je-evrardje-evrard Membre
    octobre 2013 modifié
    Hello,

    Merci pour le test déja.

    Pour les images seules:
    - Tu dois utiliser la dernière version de spxtynimce (1.4) Tu dois réenregister tes articles avec spxtynimce et tester.

    Pour les liens : <a href="data/monic2.jpg">test</a>
    - Normallement ça marche bien.

    Je peux regarder ton site en ligne pour checker les erreurs ? Regarde dans la console aussi stp à mon avis il y a une erreur javascript. Desactive tous les plugins sauf spxlightbox et spxtynimce pour voir.

    a+
  • Salut je-evrard,

    Il m'a l'air super ton plugin ! En revanche, tout comme P3ter je n'utilise pas spxtynimce. Personnellement je n'aime pas trop les éditeurs WYSIWYG, leur préférant un langage ou un code plus rigoureux.

    Est-ce qu'il n'y a vraiment aucun moyen de s'affranchir de spxtynimce, en indiquant un classe particulière par exemple ? J'ai tenté un truc du genre, mais cela n'a pas marché :
    [== HTML ==]
    <a href="data/images/escalier-petit-palais.jpg" data-spxlightbox="true"><img src="data/images/escalier-petit-palais.jpg" alt="escalier-petit-palais-1" width="262" height="500" data-spxtynimce="true" /></a>
    

    Besoin d'idées d'évasion en France et ailleurs ? C'est ici, sur frenchvadrouilleur.fr !

  • je-evrardje-evrard Membre
    octobre 2013 modifié
    Hello
    PPmarcel a écrit:
    Est-ce qu'il n'y a vraiment aucun moyen de s'affranchir de spxtynimce, en indiquant un classe particulière par exemple ? J'ai tenté un truc du genre, mais cela n'a pas marché :

    Tu peux me montrer le lien en ligne que je regarde stp ?

    Tu as essaye juste avec ça : <img src="data/images/escalier-petit-palais.jpg" alt="escalier-petit-palais-1" width="262" height="500" data-spxtynimce="true" />
  • Voici l'URL :

    http://blog.maoli.fr/test

    Je suppose qu'il y a une réécriture qui s'opère à la volée avec l'outil de rédaction. En ayant un exemple d'image utilisant ton plugin, ça me donnerais un indice sur ce qu'il faut faire figurer au final.

    Besoin d'idées d'évasion en France et ailleurs ? C'est ici, sur frenchvadrouilleur.fr !

  • Ok je viens de comprendre j'ai fait une boulette je fais une nouvelle version dans 5 minutes !!!
  • Voila la 0.8 qui devrait corriger ton soucis.
  • Précisément, ça corrige le schmilblick ! Merci. :)

    Besoin d'idées d'évasion en France et ailleurs ? C'est ici, sur frenchvadrouilleur.fr !

  • P3ter a écrit:
    Je teste ton plugin en 0.7.
    Faut-il utiliser spxtynimce pour que spxlightbox fonctionne ? Car j'utilise plxEditor et bien que le plugin ajoute les balises <a>...</a> sur les balises <img>...</img> de mes articles, la lightbox ne s'ouvre pas, et l'image s'affiche seul dans la page.

    la version 0.8 devrait corriger ton problème
  • P3terP3ter Responsable de PluXml
    Arf toujours le même soucis.
    J'ai supprimer le plugin, installé et activé la nouvelle version.
    J'ai ensuite créé un article (j'utilise toujours plxEditor) avec 2 miniatures + un lien vers l'image complète.

    Je t'envoie en MP de quoi accéder à mon site de dev.
  • ok merci P3ter
  • Bonjour,

    Merci pour ce plugin qui fonctionne merveilleusement bien !
    Je rencontre toutefois un petit problème lors de l'affichage de "popup", une barre noire se place juste au dessus de l'image (comme si y avait un padding-top).

    Merci encore, je continue mes tests =]
  • je-evrardje-evrard Membre
    octobre 2013 modifié
    Oui je vais corriger ça car il y aun rajout d'une balise <a> vide : j'y travaille pour la nouvelle version c'est encore une version de test
  • version 0.9 (23/10/2013)
    + [BUG] fix regex pour protéger lien avec image (pas de duplication de <a>)
  • P3terP3ter Responsable de PluXml
    Juste pour dire que mon problème est corrigé (merci à je-evrard). Il était lié à des erreurs javascript de mes autres plugins, à savoir ScrollToTop et FitVids.
  • je-evrard a écrit:
    Oui je vais corriger ça car il y aun rajout d'une balise <a> vide : j'y travaille pour la nouvelle version c'est encore une version de test
    Ok, merci encore !
  • Question : Ca vous intéresse que je fasse une option lightbox sur toutes les images isolées (venant ou pas de tynimce)
Connectez-vous ou Inscrivez-vous pour répondre.