Sortie de PluXml 5.5

2

Réponses

  • Bonsoir,

    Les thèmes et les plugins de la 5.4 sont-ils compatibles avec cette nouvelle version ?

    Bravo à l'équipe.
  • PierrePierre Membres
    Je n'utilise habituellement aucun plugin. Depuis le passage de Vignette à la fonction interne artThumbnail(), les thèmes que je convertis s'intègrent immédiatement à PluXml 5.5 de base à ouvrant la boîte...

    Pour les plugins, leurs concepteurs chantent le blues de la mise à jour depuis quelques semaines. Ça dépendra de ce que tu utilises, de leur interaction, de la disponibilité des concepteurs/réparateurs desdits plugins.
  • joebartjoebart Membres
    avril 2016 modifié
    Bonjour,

    J'ai mis à jour mais j'ai un souci sur tous mes thèmes : l'image d'accroche.
    Je m'y prends peut-être mal ?

    Mon site : 160407011227487556.jpg

    Le champ image bien renseigné pourtant :

    160407011326596288.jpg

    Ou alors je n'ai rien compris à l'utilisation de l'image d'accroche ?
    Cela concerne d'anciens articles que j'ai édité....
  • PierrePierre Membres
    Et que ce passe-t-il si tu passes au thème par défaut? la même chose?

    C'est toujours le meilleur test au moment de migrer à une nouvelle version. Quand tout fonctionne, on passe à des thèmes plus élaborés.
  • Bonjour Pierre, oui, même chose, je ne comprends pas. Ou alors, je ne sais pas me servir de l'accroche (je fais glisser l'image dans le champ avec le +)
  • PierrePierre Membres
    Je me questionne en voyant l'adresse explicite de l'image dans le champ d'image d'accroche. En comparant chez moi, je ne vois que le chemin relatif configuré, donc démarrant juste sous le niveau racine. Si le site existe quelque part, ce serait bien de nous donner le lien, on pourrait ainsi jeter un coup d'oeil au code rendu à l'écran et voir rapidement ce qui cloche.

    J'ai vérifié que l'image est bien présente à l'adresse en question, c'est déjà ça. Mais le chemin inscrit dans le champ d'accroche est mon suspect numéro un pour corriger.
  • Merci pour cette nouvelle version. Je vais m'occuper de mettre à jour le paquet Debian en conséquence !
  • @Pierre
    Dans tes thèmes tu fais systématiquement afficher l'image d'accroche même si l'article n'en possède pas parce que tu passes par ton script img.php
    <img src="<?php $plxShow->template(); ?>/img.php?src=<?php $plxShow->artThumbnail('#img_url'); ?>&w=765&h=496&crop-to-fit" alt="" />
    

    Voilà pourquoi on a le problème que remonte @joebart

    Pour ne plus avoir l'erreur il faut d'abord tester s'il y a une image d'accroche, et seulement si oui utiliser ton script img.php

    Sinon img.php est quand même appelé, va rien faire, mais la balise <img> va faire son rôle et essayer d'afficher l'image qui n'a pas été créée par img.php

    Consultant PluXml

    Ancien responsable du projet

  • PierrePierre Membres
    C'est pourquoi je l'ai fait passer au thème par défaut pour clarifier l'origine du problème. Mes thèmes et leurs artifices sont alors écartés de l'enquête.

    C'est vrai que je demande d'avoir une image d'accroche pour bien utiliser les thèmes que je choisis de convertir, c'est principalement pour cet aspect que je les ai choisis de toutes façons. Je ne sais pas comment faire le test de "présence d'accroche", j'ai posé la question dernièrement mais y a rien qui presse, cette option ne servira qu'en cas d'exception.
  • Pierre, je te donne le lien par mail avec accès FTP et je précised que j'ai le même souci sur le thème par défaut. Merci :)
  • PierrePierre Membres
    Il faut un site qui roule avec le problème en live, pas le code de PluXml, le thème par défaut est épuré et c'est tant mieux pour notre enquête.

    Tu n'as qu'à installer le thème par défaut et nous verrons les images brisées, le code rendu et la ligne fautive. On parle alors de la ligne rendue, pas le php.

    Ça ira vite ensuite pour identifier ce qui se passe.
  • @Pierre
    <?php if($plxMotor->plxRecord_arts->f('thumbnail')) : ?>
    <img src="<?php $plxShow->template(); ?>/img.php?src=<?php $plxShow->artThumbnail('#img_url'); ?>&w=765&h=496&crop-to-fit" alt="" />
    <?php endif; ?>
    

    Consultant PluXml

    Ancien responsable du projet

  • @joebart

    Pour ajouter une image d'accroche: tu cliques sur le +, dans la fenêtre qui s'ouvre (gestionnaire de medias) tu cliques ensuite sur le lien de l'image à ajouter. Le lien sera ajouté dans le champ image d'accroche.
    il doit ressembler à: data/images/texte-loi.jpg

    Consultant PluXml

    Ancien responsable du projet

  • PierrePierre Membres
    avril 2016 modifié
    Merci pour le code de test. Ça va pour la situation de la page d'accueil où le webmestre aurait malencontreusement envoyé (en cochant dans l'admin) un article sans image pour s'afficher sur la une. C'est déjà très bien de ne pas faire crasher un slider mais une simple mise en garde faisait presque l'affaire, on ne fait l'erreur qu'une fois habituellement.

    Mais voilà, le hic, c'est que presque toutes les utilisations que je fais de la fonction d'accroche se trouve au coeur du $format de lastArtList(). Je serais bien triste de ne plus pouvoir utiliser cette petite merveille et avoir à toujours créer une boucle WHILE. J'aime mieux rester grincheux et dire que les gens qui ne mettent pas d'images ne seront tout simplement pas mes amis! Ça va pour la cour d'école mais c'est bien aussi d'être gentil, au moins de temps en temps...
  • joebartjoebart Membres
    avril 2016 modifié
    Stéphane a écrit:
    @joebart

    Pour ajouter une image d'accroche: tu cliques sur le +, dans la fenêtre qui s'ouvre (gestionnaire de medias) tu cliques ensuite sur le lien de l'image à ajouter. Le lien sera ajouté dans le champ image d'accroche.
    il doit ressembler à: data/images/texte-loi.jpg

    Bonjour Stéphane, c'est bien ce que je fais. Je clique sur une image mais elle s'agrandit dans une nouvelle fenêtre...

    mini_160407061732405122.jpg

    Je peux la faire glisser dans le champ ou il ya le plus (voir mes screens antérieurs) mais rien, l'image n’apparaît pas...
  • @joebart: la fenetre qui s'ouvre n'est pas celle du gestionnaire de medias de PluXml. Tu dois utiliser un plugin. Donc je comprends pourquoi le comportement n'est pas celui attendu et pourquoi tu n'arrives pas à ajouter le lien d'une image dans le champ "Image d'accroche"

    Consultant PluXml

    Ancien responsable du projet

  • PierrePierre Membres
    Le problème pourrait avoir une source encore plus simple, le répertoire d'images est situé à l'extérieur du répertoire medias... Il est à côté plutôt qu'en-dessous.
  • Bon, Stéphane a bien trouvé le poblème. C'est le FileManager du plugin "spxtynimce" de Je Evrard qui posait problème.
    Je l'ai désactivé et c'est OK ;)
  • joebart a écrit:
    Bon, Stéphane a bien trouvé le poblème. C'est le FileManager du plugin "spxtynimce" de Je Evrard qui posait problème.
    Je l'ai désactivé et c'est OK ;)
    Ouf ça me rassure ;)

    Consultant PluXml

    Ancien responsable du projet

  • Hello,
    Il y a une nouvelle fonction dans la partie "admin" pour les articles.
    Articles: gestion de la date de création et de mise à jour plus date de publication.
    Est-ce que dans la partie publique, il y a une indication de ces dates dans l'article ?

    Merci
  • PierrePierre Membres
    avril 2016 modifié
    C'est utilisable très facilement avec les fonctions artCreationDate() et artUpdateDate() qui peuvent être formatées de la même façon que artDate().

    Le thème par défaut n'affiche que le dernier cas, c'est habituellement que que l'on désire comme date dans un blog.
  • Bonjour

    J'en parlais ici
    http://forum.pluxml.org/viewtopic.php?pid=47631#p47631

    Il y a ça aussi qui pourrait t'interesser
    http://forum.pluxml.org/viewtopic.php?pid=47691#p47691

    J'essaye de faire un article dans la semaine pour résumer tout ça et que ce soit pas noyé dans le forum

    edit: je viens de retrouver un post qui résume un peu tout ça
    http://forum.pluxml.org/viewtopic.php?pid=47831#p47831

    Consultant PluXml

    Ancien responsable du projet

  • Stéphane a écrit:
    Bonjour

    J'en parlais ici
    http://forum.pluxml.org/viewtopic.php?pid=47631#p47631

    Il y a ça aussi qui pourrait t'interesser
    http://forum.pluxml.org/viewtopic.php?pid=47691#p47691

    J'essaye de faire un article dans la semaine pour résumer tout ça et que ce soit pas noyé dans le forum

    edit: je viens de retrouver un post qui résume un peu tout ça
    http://forum.pluxml.org/viewtopic.php?pid=47831#p47831

    ok,
    ça fonctionne.

    Quand on créé un article, il se place automatiquement au début dans la catégorie sélectionnée, je suppose que c'est par rapport à la date de création.

    Est-il possible de mettre en premier l'article dans la catégorie par rapport à la date de mise à jour ?

    Merci
  • @jol5926: c'est trié par rapport à la date de publication. Ce n'est pas possible de trier par rapport à la date de mise à jour.

    Consultant PluXml

    Ancien responsable du projet

  • antistressantistress Membres
    avril 2016 modifié
    désolé je n'ai pas bien compris.
    J'ai bien vu que dans la console on avait la date de parution, de création et de modification. J'ai actualisé celle de modification. Cette nouvelle date devrait apparaître dans le billet (ce ne semble pas être le cas. Je précise que j'utilise le dernier thème) ?
  • @antistress: coté visiteur c'est la date de publication qui est affichée et uniquement celle là. Le thème par défaut n'affiche pas les dates de modification ou de creation. Pour les voir faut modifier le theme en conséquence en utilisant les nouvelles fonctions dédiées.

    Consultant PluXml

    Ancien responsable du projet

  • Je vais regarder ça, merci Stéphane :)
  • Stéphane, j'ai repris ton code http://forum.pluxml.org/viewtopic.php?pid=47686#p47686 dans home.php et article.php pour faire apparaître la date de modification, c'est génial, merci :)
  • antistress a écrit:
    Stéphane, j'ai repris ton code http://forum.pluxml.org/viewtopic.php?pid=47686#p47686 dans home.php et article.php pour faire apparaître la date de modification, c'est génial, merci :)

    J'avais oublié de modifier aussi tags.php et categorie.php, voilà qui est fait.

    Cette fonction est vraiment géniale, je pense qu'elle devrait être dans la prochaine version sous la forme d'une option de configuration.
    Bon, vu que ça a à voir avec le thème, je ne sais pas si c'est possible par contre...
  • ElessarElessar Membres
    Comme promis, je viens de finir l'empaquetage de cette nouvelle version, PluXml 5.5 va donc très prochainement être disponible dans Debian unstable (le temps que le paquet soit automatiquement construit, demain je pense). Avec en prime une correction inédite d'un petit bug qui rejetait les commentaires si le capcha était désactivé. :-)

    La mise à jour du paquet Debian s'occupe de la réindexation des commentaires, qui était le changement principal de cette version en ce qui concerne les données du blog.
Connectez-vous ou Inscrivez-vous pour répondre.