5.6 rc4

Bonjour, afin d’accélérer la sortie de la version 5.6, l'aide de beta testeurs est la bienvenue.

L'objectif est de tester et remonter les problèmes à partir d'une installation propre mais aussi à partir d'une mise à jour d'un site existant.

La version en cours de développement à tester est disponible sur le github de PluXml

Release Candidate 4 (15/03/2017)
https://github.com/pluxml/PluXml/releases/tag/5.6rc4

Liste des évolutions et des changements:
https://github.com/pluxml/PluXml/blob/5.6rc4/readme/CHANGELOG

===================================

Release Candidate 3 (08/03/2017)
[del]https://github.com/pluxml/PluXml/releases/tag/5.6rc3[/del]

Release Candidate 2 (03/03/2017)
[del]https://github.com/pluxml/PluXml/releases/tag/5.6rc2[/del]

Release Candidate 1 (01/03/2017)
[del]https://github.com/pluxml/PluXml/releases/tag/5.6rc1[/del]

Pre-release 3 (23/02/2017)
[del]https://github.com/pluxml/PluXml/releases/tag/5.6pre3[/del]

Pre-release 2a (17/02/2017)
[del]https://github.com/pluxml/PluXml/releases/tag/5.6pre2a[/del]

Pre-release 1a (14/02/2017)
[del]https://github.com/pluxml/PluXml/releases/tag/5.6pre1a[/del]

Pre-release 1 (13/02/2017)
[del]https://github.com/pluxml/PluXml/releases/tag/5.6pre1[/del]

Beta 1 (03/02/2017)
[del]https://github.com/pluxml/PluXml/releases/tag/5.6b1[/del]



=============================================

Si vous constater un dysfonctionnement soyez le plus précis possible dans le descriptif pour pouvoir reproduire le problème.
Il n'y a que de cette façon que l'on pourra être efficace dans la correction et dans la rapidité de traitement du problème.

Merci d'avance aux personnes qui participeront

Consultant PluXml

Ancien responsable du projet

«1345

Réponses

  • J'ai un pb sur un fil rss des commentaires d'un article.
    Visiblement le "&" pose pb si utilisé pour l'auteur. le pb semble être présent également dans la version précédente.

    BUG Mauvais lien des commentaires dans les flux rss >> OK ça marche.

    Un petit pb d'affichage dans la liste des articles (administration).
    Si le label de la catégorie est trop long, la flèche vers le bas est au milieu du label.

    Sinon, la migration n'a pas posé de pb.


    J'en profite également pour signaler qu'il est toujours possible de mettre en double ou plus un tag d'un article.
    C'est pas très grave mais ça serait bien si les doublons étaient supprimés automatiquement.


    Juste un retour rapide. J'essaie de passer plus de temps dessus si j'ai le temps.
  • Cool ! :)

    Beta téléchargée, tests dans le week-end.


    à plus,

    Gzyg
  • Content de voir que le Maestro se lance dans une nouvelle épopée.

    Mes premières requêtes reprendront des points qui ont été évoqués dans nos conversations. Pour l'instant, il me vient à l'esprit deux points qui se ressemblent un peu, le logo "d'entreprise" et l'avatar "usager".

    Pour le logo, la page de configuration de base pourrait simplement recevoir une adresse url d'une image de logo, ou encore la page de configuration avancée où sont toutes les autres adresses configurables. Le plus simple est de pointer vers un fichier chargé dans /medias. Par expérience, il arrive très souvent que cette image soit la seule chose à configurer. Un nouveau venu doit ouvrir le code et patauger en eaux peu connues pour remplacer un logo "bidon" installé dans un thème créé par un designer.

    L'avatar aurait, lui, un double usage (peut-être même plus), en servant d'identifiant dans les conversations de commentaires mais aussi dans l'information sur l'auteur. Beaucoup de gabarits offrent une petite section "À propos de l'auteur" qui comporte une photo. Je suggère d'inclure cet avatar au niveau du "compte usager" pour permettre d'en avoir plus d'un.

    Voilà pour tout de suite, faut pas abuser...
  • DenDen Membres
    Bonjour,

    Je vais installer cette version en mise à jour et je vous redonne des nouvelles.

    Merci! :)
  • DenDen Membres
    mars 2017 modifié
    La mise à jour s’est bien déroulée sans aucune anomalie pour l'instant.

    test.png

    Voici une copie d'écran des plugins utilisé et sans problème apparent pour l'instant.

    plugin.png

    La réécriture d'URL n'est pas activée...
  • Bonjour, une installation "neuve" en local et sans plugin s'est passée sans problème. Je lancerai prochainement un upgrade d'un site existant.

    Un premier retour : je trouve que les padding de .header (theme.css ligne 65) et .footer (theme.css ligne 292) à 6rem sont un peu grandes, surtout en affichage sur un mobile de petite résolution (max-width: 768px -> 1/3 de l'écran en mode vertical). Une valeur de 3rem permettrait de moins perdre de place (en laissant éventuellement 6rem à partir de min-width: 48rem).

    Sinon c'est zoli :)
  • Bonsoir stéphane,
    l'installation s'est déroulée correctement. J'en profite pour faire une toute petite requête. Serait-il possible de rajouter la classe "new" dans la balise <tr> à la ligne 123 du fichier statiques.php comme c'est déjà le cas dans le fichier categories.php (ligne 101) ?
    Merci.
  • niqnutn a écrit:
    J'ai un pb sur un fil rss des commentaires d'un article.
    Visiblement le "&" pose pb si utilisé pour l'auteur. le pb semble être présent également dans la version précédente.

    tu peux stp me donner un exemple. c'est sur le balise <dc:creator> ?

    Consultant PluXml

    Ancien responsable du projet

  • niqnutn a écrit:
    Un petit pb d'affichage dans la liste des articles (administration).
    Si le label de la catégorie est trop long, la flèche vers le bas est au milieu du label.

    corrigé
    niqnutn a écrit:
    J'en profite également pour signaler qu'il est toujours possible de mettre en double ou plus un tag d'un article.
    C'est pas très grave mais ça serait bien si les doublons étaient supprimés automatiquement.

    corrigé
    kowalsky a écrit:
    Un premier retour : je trouve que les padding de .header (theme.css ligne 65) et .footer (theme.css ligne 292) à 6rem sont un peu grandes, surtout en affichage sur un mobile de petite résolution (max-width: 768px -> 1/3 de l'écran en mode vertical). Une valeur de 3rem permettrait de moins perdre de place (en laissant éventuellement 6rem à partir de min-width: 48rem).

    corrigé
    memento a écrit:
    J'en profite pour faire une toute petite requête. Serait-il possible de rajouter la classe "new" dans la balise <tr> à la ligne 123 du fichier statiques.php comme c'est déjà le cas dans le fichier categories.php (ligne 101) ?
    Merci.

    ajouté

    Merci pour vos retours.
    N'hésite pas à remonter les problèmes.

    Consultant PluXml

    Ancien responsable du projet

  • Hello,

    Aucun soucis d'installation. Tout va bien pour le moment.

    a+

    jéjé
  • pour les groupes dans le thème de base, l'affichage reste vraiment sale et il est forcé de suivre le tuto mis sur pluxopolis afin d'avoir des menus déroulant. Sincèrement proposer un groupe mais devoir "coder" derrière je trouve que c'est un non sens, cela devrait être une fonctionnalité par défaut. D'ailleurs et c'est dommage, on se rend compte que quasiment aucun thème proposé n'est capable d'afficher correctement un groupe ce qui veut dire qu'il faut savoir modifier une CSS pour utiliser cette fonctionnalité.
  • Bonjour,

    J'ai fait quelques tests sur une tablette Asus 10" résolution 1280x800. J'ai mis quelques copies d'écran sur Google Drive. Pour y à accéder, cliquez sur le lien suivant:
    https://drive.google.com/drive/folders/0B_oPNDSijoBtWC11MC1mVk1hSUU?usp=sharing

    Voici quelques retours :
    ===============================================================
    Dans la dernière ligne des différents tableaux pour une nouvelle catégorie ou page statique ou utilisateur, on peut mettre le mot nouveau sur 2 colonnes pour éviter de gâcher de l'espaces :

    * fichier core/admin/categories.php
    ligne 103: modifier <td> en <td colspan="2"> et supprimer ligne 102

    * fichier core/admin/statiques.php
    même chose pour les lignes 125 et 124

    * core/admin/parametres_users.php
    même chose pour les lignes 107 et 106

    ===============================================================
    * Utiliser les expressions "Identifiant ..." pour le titre élargissent ENORMEMENT les largeurs des 2èmes colonnes dans la liste des articles, les pages statiques, les catégories, des utilisateurs. Il serait plus efficace de remplacer ces expressions par "N°" en français ou "#" en anglais.

    * core/lang/lang/fr.php et suivant, ajouter l'entrée suivante dans le tableau $LANG: 'L_ID' => 'N°' et modifier les titres de colonnes pour les lignes référencées ci-dessous dans les fichiers du dossier core/admin/ :
    ** index.php ligne 162
    ** statiques.php ligne 65
    ** categories.php ligne 54
    ** parametres_users.php ligne 56

    ===============================================================
    * 3 régles de style CSS à ajouter dans core/admin/theme/theme.css
    ** pour justifier à droite les nouveau ..." dans les listes ci-dessus
    .new td[colspan="2"] { text-align: right; }
    ** et pour ceux qui préfèrent le papier zoné aux pages blanches
    .scrollable-table tbody tr:nth-of-type(2n) { background-color: #eee; }
    ** Quand on a des titres longs pour les articles, on a un retour à la ligne au milieu des mots. Dans le fichier core/admin/theme/theme.css vers la ligne 210, pour éviter cela, supprimer ou mettre en commentaire la règle "word-break: break-all;"

    ===============================================================
    Sinon dans l'ensemble pas trop de souci, malgré une dizaine de plugins de mon crû.

    Quelques petits regrets :
    Dans la ré-écriture des urls, toujours des n°s après les articles ou catégories. J'avais modifié le code dans Pluxml 5.5 pour éviter cela. Il va falloir remettre les mains dans le cambouis à nouveau
    pas de possibilité d'épingler un article en standard. Donc re-cambouis
    Pourtant ça le fait sur mon site : htttp://echecs-annonay.fr

    A++
  • Autre souci plus grave :

    le nom du dossier de plugins est gravé dans le code de la bibliothèque de PluXml. Il suffit d'utiliser grep pour le voir.
    Voir copie d'écran
    Et donc impossible de changer le nom du dossier.

    Donc, tous les sites propulsés par PluXml ont un dossier plugins, comme d'ailleurs pour le dossier datas.
    Ne le répétez surtout pas aux hackers :mad: .

    D'ailleurs une possibilité sympa à l'install serait de pouvoir choisir le noms de ces 2 dossiers.
    Pour renommer le dossier datas, il y a mon plugin moveMyDatas, qui permet en plus de basculer entre différentes données/configs.

    A++
  • @bazooka07: merci beaucoup pour la pertinence des tes remarques et d'avoir pris le temps de les lister. Je vais m'occuper de tout ça

    Changer le nom du dossier plugins n'a aucun intérêt car il suffit de visualiser le code source html des pages coté visiteurs et tu verras par exemple au lieu de /plugins/plxMyContact/xxxx /tondossier/plxMyContact/xxxxx
    L'emplacement du dossier plugins est configurable dans les paramètre avancés. Dans pluxml c'est la variables PLX_PLUGINS qui fait référence à ce dossier. Si le nom "plugins" apparaît en dur ce sont des oublis au fil des évolutions de PluXml. ça ne le devrait pas. Je vais tacher de corriger ça au mieux

    En revanche si c'est en dur dans les plugins c'est une mauvaise pratique des développeurs, pas de PluXml.

    Consultant PluXml

    Ancien responsable du projet

  • bazooka07 a écrit:
    Autre souci plus grave :

    le nom du dossier de plugins est gravé dans le code de la bibliothèque de PluXml. Il suffit d'utiliser grep pour le voir.
    Voir copie d'écran
    Et donc impossible de changer le nom du dossier.

    Donc, tous les sites propulsés par PluXml ont un dossier plugins, comme d'ailleurs pour le dossier datas.
    Ne le répétez surtout pas aux hackers :mad: .

    le dossier listé par la commande grep correspond au dossier data/configuration/plugins utilisé pour le fonctionnement interne de PluXml.
    rien à voir avec le dossier plugins utilisateurs ./plugins qui lui est configurable

    ça ne me gène pas du tout que PLX_ROOT.PLX_CONFIG_PATH.'plugins' soit en dur car c'est un sous dossier de data/configuration/ qui lui est déjà censé être protégé et ne peut pas être accessible de l'extérieur. Déplacer ce dossier serait un non sens et potentiellement dangereux (surtout si l'emplacement est à l'appréciation des utilisateurs qui ne sont pas forcément des "power-users" et en mesure de le sécuriser)

    Consultant PluXml

    Ancien responsable du projet

  • bazooka07 a écrit:
    Quelques petits regrets :
    Dans la ré-écriture des urls, toujours des n°s après les articles ou catégories. J'avais modifié le code dans Pluxml 5.5 pour éviter cela. Il va falloir remettre les mains dans le cambouis à nouveau
    pas de possibilité d'épingler un article en standard. Donc re-cambouis
    Pourtant ça le fait sur mon site : htttp://echecs-annonay.fr

    A++

    Là ça m’intéresse de savoir comment tu as fais. Si je peux voir les modifs de code que tu as fait sur un github à toi, ça m'irait très bien (pas la peine dans un 1er temps de faire un pull request sur pluxml).

    Merci

    Consultant PluXml

    Ancien responsable du projet

  • @bazooka07: j'ai pris en compte tes propositions de modifications données plus haut. c'est top. merci

    Consultant PluXml

    Ancien responsable du projet

  • Consultant PluXml

    Ancien responsable du projet

  • Update en localhost osx 10.11.6 el capitan sans aucun pb .....

    j'en profite pour évoquer que je regrette tj l'ancienne interface admin (type 5.2) avec ses proportions qui permettaient de s'y retrouver dans un écran de taille réduite. ok je sais y'a ka changer le css ( pour un newbie du code c'est tj une suée )

    coté liste article pour un tag donné ==> comment modifie t on le nb d'article par page?

    merci bien
  • kristian.tz a écrit:
    coté liste article pour un tag donné ==> comment modifie t on le nb d'article par page?

    [+] Administration > Paramètres > Options d'affichage : Nombre d'articles affichés par page dans les mots clés

    Consultant PluXml

    Ancien responsable du projet

  • @Stephane,

    Dans le thème par défaut, pourquoi ne pas intégrer les menus déroulants en CSS pour afficher les groupes de pages statiques.
    D'autant que t'as fait le plus gros du job sur Pluxopolis.
    C'est pas forcément à la portée de tout le monde.

    A++
  • En fait, il y a moins de boulot que je pensais.
    J'ai posé un fichier patch sur Google Drive ici.

    Petite remarque: d'après la littérarture la règle CSS3 list-type s'applique à la balise ul et non à li.
  • Bonjour,

    Cette version me plait bien!! Maj à partir d'une 5.4 et d'une 5.5, et installation neuve.
    Aucun problème. J'utilise jquery-3.1.1.js
    Les plugins que j'utilise et qui fonctionnent :
    ckeditor 4.5.11 2016-11-09
    tinymce 1.502 2016-03-12
    plxMyContact 1.7.3 2017-01-31
    plxMySearch 1.53 2015-03-15
    admin_users_rights 1.6 2016-04-02
    MySlippry 1.1 2017-02-13
    artGallery 4.5 2016-11-22
    BackUpAll 1.4 2016-08-28
    plxSimpleStat 1.0.1 2016-06-30

    Cordialement
    et encore merci pour tout ce travail
  • @cpalo: merci pour le retour et la liste des plugins utilisés

    Consultant PluXml

    Ancien responsable du projet

  • bazooka07 a écrit:
    En fait, il y a moins de boulot que je pensais.
    J'ai posé un fichier patch sur Google Drive ici.

    Petite remarque: d'après la littérarture la règle CSS3 list-type s'applique à la balise ul et non à li.

    Je n'arrive pas à appliquer le patch
    Tool Apply Patch: defaut1/css/theme.css: No such file or directory

    Meme en renommant ou en dupliquant le dossier defaut en defaut1, ça me mets toujours la même erreur.

    Consultant PluXml

    Ancien responsable du projet

  • @Stephane,

    Il faut te placer à la racine du site.

    Sinon j'ai une archive zip pour le thème defaut1 sur Google Drive ici.
    Les fichiers modifiés sont dans le dossier css
  • @bazooka07: super. j'ai récupéré l'archive je vais me débrouiller avec ça. merci

    Consultant PluXml

    Ancien responsable du projet

  • @bazooka07:

    je pense qu'on peux faire encore + simple
    si tu veux tester en ajoutant juste ces lignes de code dans le fichier theme.css
    .menu > li ul {
    	display: none;
    	position: absolute;
    	padding: 0;
    	line-height: 2.8rem;
    }
    .menu > li:hover ul {
    	display: block;
    }
    .menu ul  li {
    	display: block;
    	margin: 0;
    	padding: 0 1rem;
    	background-color: #fff;
    }
    

    Consultant PluXml

    Ancien responsable du projet

  • bazooka07 a écrit:
    Petite remarque: d'après la littérarture la règle CSS3 list-type s'applique à la balise ul et non à li.

    Je trouve ça comme doc:

    Conditions d'application de la CSS list-style-type.

    La propriété CSS list-style-type est applicable sur les balises HTML ou XHTML ayant pour valeur display:list-item.
    La propriété CSS list-style-type peut s'appliquer directement sur la balise HTML ou XHTML LI, UL, OL.


    Source: http://www.zonecss.fr/proprietes-css/list-style-type-css.html

    Est-ce que ça serait différent en css3 ?
    Dans PluCSS list-style-type est appliqué à des <li>

    Réel problème ou pas si on veut être puriste et rigoureux dans l'écriture ?

    Consultant PluXml

    Ancien responsable du projet

  • Bonsoir,
    Stéphane a écrit:
    Est-ce que ça serait différent en css3 ?
    Non, ça n'a pas changé. La propriété CSS "list-style-type" s'applique à toutes balises HTML avec la propriété CSS display:list-item; ce qui est le cas par défaut sur les balises <ul>, <ol> et <li>. L'avantage de définir cette propriété dans les balises <ul> et <ol>, c'est que dans le cas de listes imbriquées les unes dans les autres, ça évitera certains problèmes d'interprétation CSS.
    Voir la littérature officielle pour plus de détails : https://www.w3.org/TR/css-lists-3/#list-style-property
    Cordialement
Cette discussion a été fermée.