[Plugin] kzChamPlus: Des champs en plus dans: articles, pages, catégories, users - Gestion mots-clés

13

Réponses

  • Oui, il s'agit bien du plugin kzChamPlus. l'autre plugin n'est plus maintenu.
    Je regarderai cela demain. Cela fait un petit moment que j'ai écrit ce plugin. Il faut que je me remette dedans.

  • Merci... j'allais abandonner pour ce soir, mais je suis retourné dans l'aide et j'ai coché la petite case (Désactiver l'intégration automatique des médias) dans la config du plugin...
    J'ai pas tout compris mais... Bingo, l'image s'affiche bien maintenant ! :+1:
    prochaine étape, essayer d'insérer un lien sur cette image, mais est-ce possible ?

  • Effectivement le libellé de la case à cocher prête à confusion.
    Pour le lien sur l'image, il faut faire comme ceci :

    <a href="<?php eval($plxShow->callHook('kzChamPlus', 'artLienExterne')); ?>" target="_blank">
        <?php eval($plxShow->callHook('kzChamPlus', 'artImgEntete')); ?>
    </a>
    
  • Autre méthode :

    <a href="<?= $plxShow->plxMotor->plxRecord_arts->f('cps_artLienExterne') ?>" target="_blank">
           <img src="<?= $plxShow->plxMotor->plxRecord_arts->f('cps_artImgEntete') ?>" />
    </a>
    

    Plus rapide.
    Inconvénient : la balise <img> n'a pas d'attribut width et height.
    Si l'image est longue à charger, il y a un effet visuel pas très agréable (redimensionnement de la page HTML en fonction de la taille de l'image chargée)

  • Ah ben là du coup... j'ai bien avancé, et appliqué ta 1ère méthode pour l'insertion d'un lien sur mon image, Super Merci !

  • NonoMNonoM Member
    novembre 2020 modifié

    Il me plait bien ton plugin bazooka07 ! :+1:
    et de ce fait, j'aimerais bien masquer les 3 zones champs qui me sont inutiles dans l'éditeur (image d'accroche... Titre de l'image... Texte alternatif) dans quel fichier c'est codé, une piste ?
    PS : j'ai fait une capture écran mais je ne trouve pas comment l'insérer ici, mais bon...

    EDIT : petite piste trouvée ici : https://forum.pluxml.org/discussion/6395/supprimer-le-lien-des-images-daccroche

  • NonoMNonoM Member
    novembre 2020 modifié

    Coucou, me revoilou ! (ça faisait longtemps)

    Bon j'ai trouvé... je sais que toucher le "core" n'est pas conseillé, mais je note bien de côté les modifs effectuées.
    pour obtenir ce que je voulais (masquer les 3 champs "image d'accroche, etc..." dans l'édition d'un article)
    au niveau du fichier core\admin\article.php, j'ai mis en commentaire les lignes 361 à 387 :

    ça fait un peu de ménage visuel et ça libère la place pour afficher les champs du merveilleux plugin "kzChamPlus" de Monsieur bazooka07 !!!

  • bazooka07bazooka07 Member
    novembre 2020 modifié

    Nouvelle version 2.5.0 :

    • corrections linguistiques en occitan ( contrib. @Rubén)
    • ajout des hooks pour core/admin/categories.php (contrib @flip-flip)
    • ajout des hooks pour core/admin/profil.php (voir @sken 15/06/20)
    • ajout hooks pour plxShowStaticListEnd (voir @blk 06/09/20)
    • Corrections fichier aide
    • Fix CSS

    Télécharger la dernière version de ce plugin

  • Salut bazooka07, merci... plugin mis à jour, ça roule !
    même si au niveau "aide" je ne pige pas vraiment la différence ou le résultat que l'on peut obtenir avec tel ou tel code...
    (il me faudrait des exemples en ligne pour bien faire, mais bon...)

    Une petite question :

    • Côté config de kzChamPlus, j'ai créé un champ media nommé "imagelien" et j'ai coché la case (sinon, les images ne s'affichent pas)
    • Dans mon template de catégorie, j'ai ajouté ce code
    <div class="site-content">
                <a href="categorie14/cuisine" title="Plus d'infos dans notre rubrique Cuisine !">
                <?php eval($plxShow->callHook('kzChamPlus', 'imagelien')); ?>
                </a>
                </div>
    

    Résultat : OK, les images s'affichent sous mes articles et le lien renvoie bien vers bien la catégorie "Cuisine",
    par contre au survol de la souris sur l'image, je n'ai pas le résultat attendu (Plus d'infos...), mais le nom de l'image (image01.jpg).
    une solution peut-être ?

  • Bonjour,
    Dans le fichier plugins/kzChamPlus/kzChamPlus.php vers la ligne n°887, remplacer :

    <img src="<?= $value ?>" alt="<?= $value ?>" title="<?= $title?>" <?= $attrs ?> />
    

    par

    <img src="<?= $value ?>" alt="<?= $title?>" <?= $attrs ?> />
    

    Je ferai une mise à jour ultérieurement.

  • Bonjour, Rapide et efficace... Merci bazooka07 !

  • Bonjour,
    Publication de la version 2.5.1 qui fixe 2 petits problèmes à propos des images

    • la balise <img> n'a plus d'attribut title pour ne masquer le title de son parentElement
    • il n'est plus nécessaire de cocher la case dans le panneau de config pour afficher l'image ( erreur typographique )

    Télécharger la dernière version de ce plugin

  • NonoMNonoM Member
    novembre 2020 modifié

    Salut bazooka07,
    cool, merci encore pour cette mise à jour !
    J'ai relu l'aide (hé, oui) et découvert que dans un champ de type media... on pouvait insérer un fichier PDF (par exemple),
    et que ce pdf s'ouvrait dans un autre onglet (ou fenêtre), et c'est parfait !!!
    Je vais juste essayer de faire en sorte qu'à la place du "Nom-du-fichier.pdf", on obtienne plutôt "Lire le document PDF"... à suivre
    ...
    EDIT ==> ligne 891 de kzChamPlus.php
    <a href="<?= $value ?>" target="_blank">Lire le document PDF : <?= $title ?></a>

    j'y ai cru... mais non, car même sous les articles où aucun champ n'a été rempli, on retrouve "Lire le document PDF"...

  • Bonjour,
    Il faut que tu relises l'aide à nouveau. On peut passer une chaine de format au hook dans le thème :

    <?php eval($plxShow->callHook('kzChamPlus', array('artFicheData', '<a href="#value" download>Lire le pdf</a>', ''))); ?>
    

    Ne pas oublier de mettre une vide comme 3ème élément du tableau.
    Note la présence de download pour télécharger le pdf ou l'afficher dans un onglet séparé du navigateur.

    Je publierai prochainement une mise à jour pour mieux gérer le cas où la valeur est nulle pour un média et éviter le 3ème élément vide dans le tableau ci-dessus.

  • NonoMNonoM Member
    novembre 2020 modifié

    malgré l'aide très détaillée, ça reste flou pour moi (toujours mon niveau de compréhension du code), et comme je n'ai pas d'exemples concrets de tout ce que l'on peut faire ou obtenir avec ton plugin, je rame...
    mais je suis assez tenace, et grâce à ton aide perso et tes instructions, j'arrive à me "dépatouiller" !

    J'ai donc créé un champ supplémentaire "PDF" et voici le code que j'ai inséré dans mon template :

    <?php eval($plxShow->callHook('kzChamPlus', array('PDF', '<a href="#value" target="_blank">Lire le document PDF</a>', ''))); ?>
    

    ça marche beaucoup mieux maintenant ! MERCI !
    PS: "formater" les messages sur ce forum, c'est tout un art

  • krockroc Member
    novembre 2020 modifié

    Bonjour,

    Serait-il possible que quand on met à jour un article dans l'interface de gestion de "core/admin/plugin.php?p=kzChamPlus", en changeant par exemple le contenu d'un champs, seule la date de mise à jour de l'article soit mise à jour et pas la date de publication ? Ceci afin d'éviter que l'ordre des articles soit modifié en front.

    Merci !

  • NonoMNonoM Member
    novembre 2020 modifié

    Bonjour,
    bizarre, bizarre... de mon côté, je ne rencontre pas ce problème.
    Si je change le contenu d'un champ (media par exemple), seule la date de mise à jour est prise en compte. L'article reste bien chronologiquement en place !
    (après, faut p'têtre voir côté config... pour ma part, Pluxml 5.8.2 en local et kzChamPlus 2.5.0, mais bon, j'en doute...)

  • @kroc,
    Quelles versions de PluXml et kzChamPlus utilises tu ?

    Pour un seul article, tu peux passer par l'édition d'un article pour modifier la date de publication.

    Pour plusieurs articles à la fois dans le panneau d'admin du plugin, il y a un bug dans la dernière version. je vais publier une mise à jour la semaine prochaine.

  • @bazooka07
    J'utilise PluXml 5.8.4 et kzChamPlus 2.5.0
    J'utilisais effectivement le panneau d'admin du plugin.

  • Salut,

    Est-ce que dans les prochains dev il est prévu d'ajouter un type de champ liste déroulante. L'idée est de pouvoir mettre en place un système de oui/non.

    Merci.

    J'ai un string de l'array

  • Salut,

    Ta demande englobe 2 choses différentes :

    • un select avec une liste de valeurs pour les options à définir
    • un select avec seulement 2 valeurs possibles pour les options "oui/non" ou plutôt "1/0" pour éviter des soucis de traduction.

    Pour la 1ère il faut définir une façon de saisir cette liste variable d'options
    Pour la 2ème, c'est plus simple. C'est un checkbox qui ne veut pas dire son nom. Mais il sera obligé de l'avouer dans la version 6.0 de PluXml :
    copie écran

  • Salut,

    Effectivement j'ai englobé le oui/non et une liste libre de valeur. De cette façon tu n'a q'uun type de champ à gérer au lieu de deux.

    Pour ce qui est fait des valeurs on va dire que ce n'est pas le problème du plugin mais du mainteneur du site.

    J'ai un string de l'array

  • cpalocpalo Member

    @bazooka07
    Bonjour
    J'utilise la version de développement 5.8.7 et mon thème est avec css grid-layout.
    Mes articles (mode static) en pleine page sont dans une grille avec trois colonnes : 2 latérales et le contenu principal au centre.
    Suivant la classe que j'attribue, j'ai des blocs qui peuvent se retrouver dans les barres latérales en contenu complémentaire de l'article.
    Est-ce qu'il est possible d'attribuer des classes personnalisées aux champs créés par le plugin pour que ces champs se retrouvent automatiquement dans les barres latérales?

  • Bonjour,
    Je suppose que tu parles côté site.
    Ce sont les emplacements dans tes templates où tu as placé le code PHP pour appeler le hook qui vont déterminer où seront affichés les nouveaux champs. Après tu peux ajuster la position dans la colonne avec un peu de CSS.

  • cpalocpalo Member
    20 avril modifié

    Bonjour,
    ça j'ai déjà fait et ça fonctionne.
    En fait c'est lors de la rédaction d'un article que je voudrai obtenir ce résultat. Il faudrait que je mette un exemple en ligne pour mieux me faire comprendre.
    Mais je pense que la solution passe plutôt par la personnalisation de TinyMce en ajoutant dans le menu insetion d'un bloc personnalisé du genre :

    $style_formats = array (
    ......
    // Style "SideNote Right"
        array (
        'title' => __('SideNote Right'),
        'block' => 'aside',
        'classes' => 'sidenote--right',
        'wrapper' => true
        )
    );
    
  • Bonjour, bonsoir
    @bazooka07 Le <?php eval($plxShow->callHook('kzChamPlus', Image)); ?> qui est inséré dans mon article en tant qu'image, n'est point une image mais l'url à la place. un bug?
    version du pluxml-user utilisé.
    cordialement votre.

    I'm the Doctor, and I declare this war is over!

  • Bonsoir,
    Dans la config du plugin, vérifie que la case "Désactiver l'intégration automatique des médias" est bien décochée.
    Dans ce cas il sera affiché une balise <img> avec la valeur de src qui va bien .
    Je n'ai pas testé avec pluxml-user mais il ne devrait pas avoir de souci.

  • Bonjour bonjour @bazooka07
    "Désactiver l'intégration automatique des médias" est bien décochée.
    Dans ce cas il sera affiché une balise image avec la valeur de src qui va bien . "
    Je viens de tester, j'ai coché la case, et . . .
    L'image viens d'apparaître sur mon article,
    Dite moi, elle ne devrait pas faire l'effet inverse?
    Cordialement . . .

    I'm the Doctor, and I declare this war is over!

  • Bonjour à tous et @bazooka07 .
    J'essaye de faire un copier coller des codes concernant les médias pour l'utiliser en background.
    Dans le fichier php du plugin, quel code permet d'envoyer une image en arrière plan?
    Merci
    amicalement vôtre.

    I'm the Doctor, and I declare this war is over!

  • bazooka07bazooka07 Member
    22 avril modifié

    Bonjour,

    Pour mettre une image en background, il faut utiliser du CSS.
    Le problème est que le CSS d'un thème ignore complètement PluXml. C'est à dire qu'il est incapable de lire la configuration de PluXml pour trouver le dossier où sont stockées les photos.
    Pour une seule image en background, le plus simple est de la mettre dans le dossier img de ton thème et d'ajouter la règle suivante dans theme.css :

    .background {
        background: url('../img/image.jpg') no-repeat center center;
        background-size: cover;
    }
    

    En supposant que le container (<div> ?) du background a la class background.

    Après il y a d'autres solutions qui dépendent de ce qu'on veut faire.

Connectez-vous ou Inscrivez-vous pour répondre.