[plugin] MySearch: moteur de recherche

123457»

Réponses

  • Merci du conseil.
    Mais j'obtiens seulement [== PHP ==] en tête de ma sidebar.
    Voir ici :
    http://belcikowski.org/PluXml/article44/pierre-sidoine-janets-wihm-ou-le-caprice-de-jeannette
  • bazooka07bazooka07 Membres
    novembre 2018 modifié
    As tu installé d'autres plugins ?
    Donne la liste.

    Le fichier sidebar.php de ton thème doir ressembler à ceci :
    https://pastebin.com/crKtDJ2e

    J'ai fait une installation toute fraiche et je n'ai pas ce souci.
  • belcikowski a écrit:
    Mais j'obtiens seulement [== PHP ==] en tête de ma sidebar.

    Il faut enlever ce [== PHP ==] (donné par l'éditeur du forum).

    As-tu activé ce pugin ?
  • J'ai enlevé le [== PHP ==].
    J'ai mis à jour le fichier sidebar.php. J'ai maintenant le champ de recherche sur mon site. Mais la recherche ne marche pas.
    La page Rechercher dit toujours "en cours de rédaction". Et impossible d'enregistrer la configuration du plugin : "erreur pendant la configuration des données".
  • Bon, j'ai supprimé la page Rechercher, puisque si j'ai bien compris, elle n'est pas nécessaire.
    Mon champ de recherche apparaît sur mon site. Mais c'est tout.
    Je ne sais sans doute pas remplir le panneau de configuration du plugin...

    Autre observation au passage : je suis sous Mac OS. Les plugins n'apparaissent pas correctement sous Safari. Il me faut utiliser Firefox pour gérer les plugins.
  • Je n'ai pas d'autre plugin dans mon PluXml.
  • bazooka07bazooka07 Membres
    novembre 2018 modifié
    Il semble qu'il y a un problème de droits en écriture pour les fichiers. Je n'ai pas de mac mais Linux et c'est un peu pareil.
    Dans le menu d'administration, cliquer sur "paramètres", puis sur "informations".

    Dans la page qui s'affiche, aucun texte ne doit être en rouge. Cela doit être écrit en vert ou en noir.
    Je ne connais pas OS X mais sous Linux on se met à la racine du site, on se logge en tant qu'administrateur et on fait
    [== Indéfini ==]
    chmod -R ug+wX data plugins
    

    Pour Safari, il faut que je l'installe sous Windows. Il y a des différente d'affichage entre les navigateurs mais on peut les corriger en général.
    Peux-tu faire une copie d'écran quand cela s'affiche mal.
  • Je ne sais pas faire ce à quoi tu m'invites [fille blonde :) ]
    Je sais faire seulement cela :

    [img]href="http://belcikowski.org/PluXml/data/medias/2018-10/core.jpg[/img]
    [img]href="http://belcikowski.org/PluXml/data/medias/2018-10/parametres.jpg[/img]

    Voici maintenant ce que donne l'affichage des plugins :
    1. Sous Safari. J'avais d'abord essayé d'installer le plugin Google Analytics. Je l'ai ensuite supprimé. Mais il ne disparaît pas de l'écran.
    [img]href="http://belcikowski.org/PluXml/data/medias/2018-10/safari.jpg[/img]

    2. Sous Firefox.
    [img]href="http://belcikowski.org/PluXml/data/medias/2018-10/firefox.jpg[/img]
  • Sur la dernière image sous Firefox, "Plugin non configuré" : cela ne te gêne pas ? [ Blonde avec jambes poilues ? ] ]:D
    cliquer sur "configuration", puis sur bouton "enregistrer" !!!

    Pour la première image, laisse le dossier "core". Il faut le faire avec les dossiers "data" et "plugins" et cocher "récursivement" puis cliquer sur bouton "ok".

    Pour Safari, je vais voir à l'installer sous Windows qui me donne des boutons partout.
  • Eh non, cela ne me gêne pas ; ou plutôt cela me gène beaucoup, car comme je te l'ai dit plus haut, quand je clique sur Enregistrer, j'obtiens ceci :

    [img]href="http://belcikowski.org/PluXml/data/medias/2018-10/erreur.jpg[/img]
  • Cela devrait pourtant. Tant que cette erreur ne sera pas résolue, tu n'avanceras pas.
    Ouvre ton gestionnaire de fichiers et corrige les droits comme suit :
    belcikowski.jpg
  • belcikowskibelcikowski Membres
    novembre 2018 modifié
    Eh bien, j'ai corrigé les droits comme suit. Et RIEN ! Même échec.
    Il semble que Mac OS n'enregistre pas ici mon choix "Récursif".
    "Établir accès", Yummy FTP ne veut pas.
  • Et je suis l'administrateur...
  • Tu peux faire la même chose avec le dossier data/configuration/plugins ?

    Je ne connais pas Yummy. Et en plus il semble payant.
    Essaie d'installer Filezilla sur ton Mac :
    https://filezilla-project.org/download.php?type=client
    C'est un client très populaire sur Windows, Linux et OS X apparemment.
    Il affiche les droits sur les fichiers et permet de les modifier
  • Merci de tes préconisations.
    Je ne serai pas connectée jusqu'à vendredi. Mais je ne reprendrai notre échange dès mon retour.
  • Je suis encore là...
    Tu m'invites à modifier les autorisations suivantes : data/configuration/plugins
    Mon arborescence est un peu différente. Vois plutôt :
    [img]href="http://belcikowski.org/PluXml/data/medias/2018-10/data.jpg[/img]
  • bazooka07bazooka07 Membres
    novembre 2018 modifié
    belcikowski a écrit:
    Je suis encore là...
    Tu m'invites à modifier les autorisations suivantes : data/configuration/plugins
    Mon arborescence est un peu différente. Vois plutôt :
    [img]href="http://belcikowski.org/PluXml/data/medias/2018-10/data.jpg[/img]
    Ce n'est pas normal. Ce n'est pas une installation standard de PluXml.
    Il doit y avoir un dossier plugins.
    Vérifie si tu l'as sur ton Mac. Sinon, crée le. Même chose sur le serveur.
  • @belcikowski

    Je suis cette conversation depuis un moment et je brûle de te conseiller d'installer sur ton hébergement un nouveau Puxml en suivant cette fois la procédure toute simple d'installation.

    Notre CMS est ainsi fait que c'est tout à fait possible et même conseillé pour procéder à des tests.
  • C'était là le problème !
    Ça y est, c'est bon ! ça marche !
    Mille mercis de m'avoir aidée, et merci aussi de ta patience.

    Et maintenant une autre question (quelle enquiquineuse !).
    Tu me faisais remarquer récemment que j'avais dans les titres de mes articles des balises imbriquées.
    Que puis-je faire pour remédier à ce défaut ?
    Christine Belcikowski
  • Merci aussi au conseil d'installation d'un PluXml de teste
    .
    Ancienne utilisatrice de Wordpress, j'ai quitté la barque pour plus de simplicité. J'apprends. Et, comme je ne suis pas du genre programmeur, je peine un peu parfois à comprendre des conseils, qui peuvent me sembler sibyllins. Mais je m'applique :) :) Et je me passe d'un éditeur de texte, préférant coder à la main. C'est un peu bien, ça, n'est-ce pas ?
  • Bonjour,

    Oui c'est un peu bien !!
    Bienvenue au club de ceux qui pratiquent ainsi.

    Cordialement
  • bazooka07bazooka07 Membres
    novembre 2018 modifié
    A) C'est bien de coder à la main. Cela permet de comprendre comment s'affiche une page HTML.
    Mais on s'expose aussi davantage aux erreurs
    "Errare humanum est, perseverare diabolicum" comme ils disent sur Wikipédia.
    Pour mieux détecter ces éventuelles on utilise un éditeur à coloration syntaxique. Quand il détecte une erreur, il affiche le texte dans une couleur différente.
    Bien souvent, il ferme automatiquement les balises HTML. tu tapes "<p>". Il écrit automatiquement "<p></p>" en plaçant le curseur au milieu.
    Tu devrais installer le plugin Codemirror qui t'apportera un peu plus de confort. Il se télécharge avec le lien ci-dessous :
    https://kazimentou.fr/pluxml-plugins2/index.php?plugin=codemirror&download

    B) Pour éviter d'avoir à taper en permanence '<p style="text-align: justify;">' à la place de '<p>', tu peux écrire une régle générale dans le fichier theme/defaut/css/theme.css :
    [== CSS ==]
    article[id^="post-"] { text-align: justify; text-indent: 1.5rem; }
    
    Cette ligne, sans le "[== CSS ==]", est à insérer avant la ligne contenant "/*
    Footer
    */"

    C) Quand tu as une liste d'objets avec une numérotation, a la place d'utiliser
    [== HTML ==]
    <p style="text-align: justify;"><span style="font-size: small;">1. entrée 1 ....</p>
    <p style="text-align: justify;"><span style="font-size: small;">2. entrée 2 ....</p>
    <p style="text-align: justify;"><span style="font-size: small;">3. entrée 3 ....</p>
    ....
    
    tu peux écrire :
    [== HTML ==]
    <ol style="font-size: small;">
       <li>entrée 1 ....</li>
       <li>entrée 2 ....</li>
       <li>entrée 3 ....</li>
        ....
    </ol>
    
    C'est sémantiquement plus correcte. tu annonces clairement que tu vas lister quelques choses. Et Cela aide les personnes avec un handicap visuel.

    D) Tes articles sont longs. En page d'accueil, le premier, voire le deuxième article occultent tous les autres.
    Il faut être très motivé pour aller voir les autres. et c'est chronophage.
    Tu devrais utiliser les chapô dans l'édition des articles ( courte introduction d'un article (teasing) )
  • bazooka07 a écrit:
    @Deevad,
    Va sur ton site et affiche le code source de la page HTML, il y a des balises <a> imbriqués pour le titre des articles. Pas cool !

    Oh! merci Bazooka07! Réparé. :)
  • @bazooka
    Très sympathique Codemirroir
    Merci
  • Bonsoir à tous,
    Comme j'ai le sentiment de bénéficier de votre indulgence, je me risque à une nouvelle question : comment partager une vidéo youtube sur PliXmel ?
    J'ai saisi ceci :
    <iframe width="560" height="315" src="https://www.youtube.com/embed/nITEU4fsqCU"; frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
    puis ceci :
    <p><div class="frame"><iframe width="560" height="315" src="https://www.youtube.com/embed/nITEU4fsqCU"; frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></p>
    Mais dans un cas comme dans l'autre, la vidéo ne s'affiche que si l'on recharge la page.
    Qu'est-ce qui manque ?
    Cf. http://belcikowski.org/PluXml/article46/vive-la-science-la-musique-mecanique
    Christine Belcikowski
  • Merci à Bazooka07 pour l'indication du plugin Codemirror.
    Il est très bien.
    Je me suis rangée aussi, dans les articles longs, au principe du chapô.
    Amitiés,
    Christine Belcikowski
  • Bonjour,

    l'un d'entre vous aurait il chercher à inserer qq lignes de code dans ce plugin afin d'obtenir une auto-complementation? Mon objectif serait d'auto-completer sur la base des tags. Merci bien.

  • Notre temps est la seule monnaie vraie ;)

    Site - Dépôt - MyShop

Connectez-vous ou Inscrivez-vous pour répondre.