[plugin] kzMarkdown : Rédigez le contenu de vos articles au format Markdown

bazooka07bazooka07 PluXml Project Manager
21 févr. modifié dans Plugins

Ce plugin permet de rédiger le contenu au format Markdown.

  • On peut avoir un aperçu en cours de rédaction. Le rendu est opéré par le serveur en PHP.
  • Contrôle sommaire de l'orthographe.
  • Utilisation du gestionnaire de médias de PluXml pour insérer des photos

Télécharger la dernière version de ce magnifique plugin

  • 2022-02-21 : version 0.9.1 : Correction archive zip (admin.css manquant)


  • 2020-02-26 : version 0.9.0 : Première publication

Réponses

  • Merci Bazooka07

  • 👍️👍️👍️ Merci!

  • ThatooThatoo Member

    Super extra!
    Bravo!
    Est-ce qu'il pourrait fonctionner pour les pages statiques aussi?

  • mlomlo Member

    Bonjour,
    merci pour le plugin.
    Chez moi (5.8.7) il ne se passe rien et je ne vois pas l'interface markdown.
    Le plugin est-il compatible avec la version 5.8.7 ?

  • mlomlo Member
    21 févr. modifié

    Merci. Même résultat pour moi : pas d'éditeur visible. Y a-t-il quelque chose à activer quelque part ?

  • bazooka07bazooka07 PluXml Project Manager

    Bonjour,
    Je viens de faire une installation neuve de la dernière version de PluXml et installer le plugin kzMarkdown.
    Tout se passe bien et on peut créer un article en markdown.

    Désactive et réactive le plugin pour que le cache CSS de PluXml se mette à jour.
    As-tu installé et activé d'autres plugins ?

  • mlomlo Member

    Merci, je viens de désactiver/réactiver. Et désactiver les 3 plugins que j'avais. Il ne reste plus que kzMarkdown et je ne vois par l'interface. J'ai effacé le plugin, l'ai remis en le reprenant à partir du lien de téléchargement. Et rien dans l'interface, comme s'il n'était pas actif.

    J'ai ça côté serveur: 
    PluXml version 5.8.7 (encodage UTF-8)

    Version de PHP : 7.4.27
    Apache
    
  • bazooka07bazooka07 PluXml Project Manager
    • As-tu essayé de créer un nouvel article ?
    • Regarde les fichiers de logs de Apache pour voir s'il y a des messages d'erreur
    • Avec ton navigateur ( Firefox ? ) ouvre la fenêtre pour les "outils de développement web" raccourci clavier F12 et regarde s'il y a des messages d'erreur dans l'onglet console
  • mlomlo Member
    22 févr. modifié

    Voici ce que j'ai comme erreur :

    Si je vais à l'adresse de easymde.min.js ça affiche : 

      Forbidden
    
    You don't have permission to access this resource.Server unable to read htaccess file, denying access to be safe
    
    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    
  • bazooka07bazooka07 PluXml Project Manager

    A partir du dossier du plugin, vérifie que tu as bien le fichier suivant :

    easy-markdown-editor/dist/easymde.min.js
    

    Voici l'arborescence de tous les fichiers dans le dossier du plugin :

    ├── build.sh
    ├── css
    │   └── admin.css
    ├── easy-markdown-editor
    │   └── dist
    │       ├── easymde.css
    │       ├── easymde.min.js
    │       └── sprites.svg
    ├── icon.png
    ├── icon.svg
    ├── infos.xml
    ├── kzMarkdown.php
    ├── lang
    │   ├── de.php
    │   ├── en.php
    │   ├── es.php
    │   ├── fr.php
    │   ├── it.php
    │   ├── nl.php
    │   ├── pl.php
    │   ├── pt.php
    │   ├── ro.php
    │   └── ru.php
    ├── lang.php
    ├── notes.txt
    ├── parsedown
    │   ├── composer.json
    │   └── Parsedown.php
    ├── renderer.php
    ├── style.css
    └── update.sh
    
  • mlomlo Member

    Oui, il est bien là.

  • mlomlo Member
    22 févr. modifié

    Le plugin suneditor, qui a aussi un suneditor.min.js dans le dossier dist, fonctionne normalement.

    En revanche le plugin plxsimplestat a le même problème d'erreur 403 pour plusieurs fichiers y compris des .png

  • bazooka07bazooka07 PluXml Project Manager

    Une erreur 403, c'est qu'il y a un problème de droits. Quand j'essaie d'ouvrir le lien https://www.nosliensvivants.fr/plugins/kzMarkdown/css/admin.css, j'obtiens le message d'erreur ci-dessous. Ce n'est pas normal !

    Forbidden
    You don't have permission to access this resource.Server unable to read htaccess file, denying access to be safe
    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    

    Il faut regarder les fichiers .htaccess à la racine du site, dans le dossier plugins, ...
    Désactive aussi la redirection d'urls dans PluXml.

  • mlomlo Member
    23 févr. modifié

    Merci, l'option "Activer la réécriture d'URL" était déjà sur "non" (c'est celle-ci pour la redirection d'url ? Je n'ai pas va autre chose).

    .htaccess de la racine du site fait 0 octet

    celui du dossier plugin fait 16 octet et contient

    Options -Indexes
    

    Que faut-il vérifier dans ces fichiers ?

    Merci pour tes conseils.

  • bazooka07bazooka07 PluXml Project Manager

    D'après le message d'erreur, ton serveur n'arrive pas à lire un fichier .htaccess. Et donc par sécurité, il refuse la lecture de tous les fichiers.
    Puisque le fichier .htaccess à la racine du site a une taille nulle, supprime le. PluXml en créera un nouveau s'il en a besoin (réécriture d'urls).
    Avec ton logiciel de ftp, vérifie les droits en lecture pour le propriétaire des fichiers ou dossiers suivants :

    • plugins/
    • plugins/.htaccess
    • plugins/kzMarkdown/

    Regarde également les fichiers de log de Apache. Ils contiennent peut-être des infos sur les messages d'erreur.
    D 'après Netim, tu peux les télécharger par ftp.

  • mlomlo Member
    23 févr. modifié

    Merci, j'ai effacé le .htaccess :
    Il est recrée à 0 si l'option "Activer la réécriture d'URL" est sur "non"
    Il est recrée avec du code si "Activer la réécriture d'URL" est sur "oui"

    Les droits sont bien en rw pour le propriétaire pour tous les fichiers (en revanche pour les autres droits ça varie selon les fichiers, et parfois pour des plugins différents le fichier équivalent a des droits différents.

    Je n'ai pas vu d'erreurs dans les fichiers de log Apache (si j'ai bien vu les bons) : il y a toutes les connections diverses mais pas d'erreurs.

    Étrangement l'icône du plugin est devenue visible, puis quand j'ai effacé et rebasculé le plugin elle ne l'était plus (erreur 403), en recommençant elle l'était à nouveau. Je ne comprends pas pourquoi.

  • Bonjour @mlo c'est Stéphane de La Voie Libre ;-), je viens d'établir une vérification des permissions sur .htaccess et j'ai également retirer modsecurity qui à causer quelques soucis vis à vis de mon blog hébergé chez moi aussi petitpouyo.fr.

  • mlomlo Member

    Hello, merci @bazooka07 et @petitpouyo

    c'est réglé, c'était bien un problème de droits de dossier contenant les css.

    Ça aura au moins permis de voir qu'il manquait le fichier admin.css dans la 0.9.0 :)

    Merci encore pour le plugin !

  • bazooka07bazooka07 PluXml Project Manager

    lol !!
    lorsqu'on tape dans le navigateur nosliensvivants.fr, on est dirigé vers http://nosliensvivants.fr au lieu de https://nosliensvivants.fr. Google n'aime pas cela. Et donc cela nuit au référencement de ton site.
    Paramétrer sur le serveur la redirection automatique vers le protocole https (Let's Encrypt t'aidera)

  • mlomlo Member
    24 févr. modifié

    ah oui, j'avais cru voir ça rapidement… merci du rappel !

  • @mlo et @bazooka07 c'est bon je viens de corriger la redirection automatique de http vers https

  • mlomlo Member

    Merci @petitpouyo !

  • mlomlo Member
    25 févr. modifié

    Bonsoir, J'ai commencé à utiliser ce plugin indispensable pour moi vu que j'utilise beaucoup le markdown, merci encore de l'avoir adapté.

    J'ai trois soucis : 

    • le code html n'est pas reconnu (par exemple : < br >) : comment faire un saut de ligne ? [edit : les < br > sont maintenant reconnus]

    • le scrolling de la partie visualisation est bloqué, et celui du code ne commande pas celui de la partie visualisation (Firefox)

    Ces deux là fonctionnent sur le site démo d'easyMDE.

    • la coloration des mots qui colore un mot sur deux (pareil sur le site démo).
  • mlomlo Member

    Bonjour,
    y a-t-il un moyen de l'activer pour les pages statiques ?

Connectez-vous ou Inscrivez-vous pour répondre.