[plugin] CKEditor: editeur wysiwyg

1356718

Réponses

  • version 1.4.5 (28/06/2012)
    [+] Sélection du thème pour la coloration syntaxique à partir de l'écran de configuration du plugin ckeditor
    [+] ckeEditor: Mise en évidence des lignes de code dans la balise <pre>
    [BUG] Pas de coloration syntaxique avec la réécriture d'url activée

    Consultant PluXml

    Ancien responsable du projet

  • Jerry WhamJerry Wham Membres
    juin 2012 modifié
    Niquwel !!!
    Deux petites améliorations mineures que l'on pourrait apporter :

    1) mettre un padding-top et un padding-bottom à 10px à la classe syntaxhighlighter afin d'avoir un peu d'espace et que la lecture du code soit plus agréable
    2) modifier la couleur de la bordure de la balise pre (de #E0DFE3 à #A1A1A1) car en fonction du contraste de l'écran avec lequel on regarde, la bordure est quasi invisible avec cette couleur (j'ai fait ça un peu vite, désolé).


    Quoiqu'il en soit, le plugin est fonctionnel en l'état. Merci beaucoup. Le sélecteur de thèmes est trop bien !


    PS : si une adresse email est entrée en commentaire dans le code (par exemple dans la description d'une fonction), elle est obfusquée par ckeditor. Il faut remplacer l'@ par (at) pour éviter ça. Le point positif est que si on laisse le @, le bug vers la redirection du cache du navigateur dont je parlais un peu plus haut n'apparait plus.
  • bg62bg62 Membres
    superbe plugin !
    vous faîtes bien la paire sur ce coup là :)
    merci
  • Je viens de tester ckeditor en local via easy php.

    Tout semble bien marcher sauf la partie url image. (config par default data/)

    En effet quand je fais :

    - insertion d'image
    - explorer le server
    - je vois bien les images dans le répertoires /data/images/
    - double clique sur une image se trouvant sur data/images/
    - en retour sur les propriétés de l'image j'ai : /images/monimage.jpg alors que je devrais avoir /data/images/monimage.jpg
    - ce qui fait que le lien n'est pas bon

    Quelqu'un a déja constaté ça ?

    Merci de votre réponse.
  • Si tu enregistres ton article, normalement le chemin relatif de l'url est transformé en chemin absolu.
  • aruhunoaruhuno Membres
    juillet 2012 modifié
    Pratiquement parfaite !


    Je m'explique quand même hein. Le travail est remarquable, la barre n'alourdie pas spécialement l'interface d'administration, elle est complète, sobre et personnalisable, mais... oui y'a toujours un mais, les iFrame pour l'intégration des vidéos Youtube ne tienne pas compte de ceci.


    Je m'excuse du retour tardif, mais je viens seulement de commencer à basculer en version 5.1.6 et comme à mon habitude, je test de nouveau les plugins qui m'ont plu et qui me semblaient pas assez évolués avant.


    Là, je tire mon chapeau, la barre est idéale pour l'utilisation que j'en fait (si je tiens pas compte du problème de superposition).


    J'espère avoir contribuer à aider un peu et remercie toute l'équipe de PluXML pour son travail titanesque !


    PS : c'est du gadjet, mais ça serai pas mal de pouvoir personnaliser quels boutons on affiche (en tenant compte de tout les boutons) et aussi permettre la personnalisation des liens et balise image (j'utilise pirobox et je veux que tout les liens externes à mon site soit en target _blank)
  • Hello.

    Je passe juste ici après avoir testé ce super plugin, simplement pour dire merci pour tout le boulot effectué. Vraiment génial !

    Merci :)
  • Excellent plugin ;)
    Ne connaissez vous pas un moyen d'enlever la toolbar dans le texte généré avec les balises <pre> </pre>
    Il y a à chaque fois une point d’interrogation dans l'angle en haut à droite . Même si je sais que c'est peut être pas très repectueux envers le responsable c'est pas très très beau sur un site web....

    Merci ;)
  • DimitriUSS a écrit:
    Excellent plugin ;)
    Ne connaissez vous pas un moyen d'enlever la toolbar dans le texte généré avec les balises <pre> </pre>
    Il y a à chaque fois une point d’interrogation dans l'angle en haut à droite . Même si je sais que c'est peut être pas très repectueux envers le responsable c'est pas très très beau sur un site web....

    Merci ;)
    Après la ligne 378, tu ajoutes :
    SyntaxHighlighter.defaults[\'toolbar\'] = false;
    
    juste avant la ligne
    SyntaxHighlighter.all();
    
  • version 1.4.6 (17/07/2012)
    [+] Plugin syntaxhighlighter: aménagement css
    [+] Prise en compte de la transparence des iframes pour éviter l'affichage d'images en dessous des vidéos

    Consultant PluXml

    Ancien responsable du projet

  • aruhunoaruhuno Membres
    juillet 2012 modifié
    La vache ! Quelle réactivité, je suis jaloux ^^

    Bon allez hop, j'adope.

    Un grand merci pour les modifications déjà apportée et bon courage pour la suite.
  • J'ai un problème... quand je veux ajouter une image à l'aide du plugin, impossible d'afficher le contenu du serveur... comme s'il n'y avait rien dans data\ alors que c'est plein d'images ! Si je demande de rafraîchir j'obtiens ceci : "Firefox ne sait pas ouvrir cette adresse car le protocole (kcact) n'est associé à aucun programme." Le Problème est le même avec Opera et IE...
  • thidal a écrit:
    J'ai un problème... quand je veux ajouter une image à l'aide du plugin, impossible d'afficher le contenu du serveur... comme s'il n'y avait rien dans data\ alors que c'est plein d'images ! Si je demande de rafraîchir j'obtiens ceci : "Firefox ne sait pas ouvrir cette adresse car le protocole (kcact) n'est associé à aucun programme." Le Problème est le même avec Opera et IE...
    Même problème sous Chrome ><
  • thidal a écrit:
    J'ai un problème... quand je veux ajouter une image à l'aide du plugin, impossible d'afficher le contenu du serveur... comme s'il n'y avait rien dans data\ alors que c'est plein d'images ! Si je demande de rafraîchir j'obtiens ceci : "Firefox ne sait pas ouvrir cette adresse car le protocole (kcact) n'est associé à aucun programme." Le Problème est le même avec Opera et IE...
    Dans la page de configuration du plugin, vérifie que le dossier de stockage des fichiers est bien "data/"
  • thidal a écrit:
    J'ai un problème... quand je veux ajouter une image à l'aide du plugin, impossible d'afficher le contenu du serveur... comme s'il n'y avait rien dans data\ alors que c'est plein d'images ! Si je demande de rafraîchir j'obtiens ceci : "Firefox ne sait pas ouvrir cette adresse car le protocole (kcact) n'est associé à aucun programme." Le Problème est le même avec Opera et IE...

    Bonjour à tous,
    J'ai le même souci avec la dernière version alors que tout fonctionnait bien jusqu'à la précédente : Impossible d'accéder au contenu du serveur pour les images...
    Je surfe avec Chrome.
  • Chez moi ça marche nickel quel que soit le navigateur ou l'herbergeur (local ou din'hosting)
  • joebart a écrit:
    Bonjour à tous,
    J'ai le même souci avec la dernière version alors que tout fonctionnait bien jusqu'à la précédente : Impossible d'accéder au contenu du serveur pour les images...
    Je surfe avec Chrome.
    Exactement pareil, avec data/ de bien renseigné et quelque soit le navigateur. Fonctionnait parfaitement avec l'ancienne version (oui je sais, c'est moi qui ai demandé les modifs ^^).
  • version 1.4.7 (24/07/2012)
    [+] Mise à jour ckeditor version 3.6.4
    BUG ckeditor: mauvaise prise en compte des liens absolus/relatifs

    Consultant PluXml

    Ancien responsable du projet

  • aruhunoaruhuno Membres
    juillet 2012 modifié
    Merci encore pour ta réactivité, et ça marche parfaitement pour moi.


    Maintenant je vais t'embêter : pourrais-tu intégré une box image (pirobox par exemple) à PluXML ou à ce plugin.


    Sinon, demande moins chiante, mais importante tout de même, peux-tu ajouter la gestion des utilisateurs à l'explorateur de fichiers de ton plugin ? Je vois le dossier de tout le monde et non que le miens comme avec plxEditor.


    Bon courage et merci encore pour ton travail =]
  • Merci pour ton retour aruhuno.
    J’espère que le problème d'accès aux images est résolu.
    Si d'autres personnes qui avaient le souci peuvent confirmer la résolution du bug...
    Sinon je vais regarder pour tes demandes.

    Consultant PluXml

    Ancien responsable du projet

  • Bonsoir,

    Le problème reste le même pour moi, j'ai une fenêtre en bas qui s'ouvre de Chrome : KC Finder./images
  • Bonjour joebart

    Est-ce que tes images sont stockées dans /data/images ?

    Consultant PluXml

    Ancien responsable du projet

  • nettoie également le cache de ton navigateur et vérifie le paramètrage suivant:
    - paramètre "Racine du site" avec un slash à la fin dans les paramètres de PluXml
    - configuration du plugin ckeditor, ligne "Répertoire de stockage des fichiers (chemin relatif)": avec la valeur data/ (ne pas oublier le slash à la fin) si ton dossier images et dans data/images/

    Consultant PluXml

    Ancien responsable du projet

  • Bonjour Stéphane, alors autant pour moi, j'ai vidé le cache et ça fonctionne :)
  • joebart a écrit:
    Bonjour Stéphane, alors autant pour moi, j'ai vidé le cache et ça fonctionne :)

    Ha super, ça me rassure. je vais pouvoir sortir la version suivante de ckeditor dans la journée :p

    Consultant PluXml

    Ancien responsable du projet

  • version 1.4.8 (25/07/2012)
    [+] Ajout du plugin Lightbox plus: effet de zoom sur les images


    Activation du plugin Lightbox
    1. Aller dans la congifuration du plugin CKEditor
    Paramètres > Plugins > lien Configuration
    2. Dans le déroulant "Lightbox plus", sélectionner la valeur "Oui"
    3. Enregistrer la configuration


    Comment utiliser le plugin LightBox pour CKEditor
    1. Cliquer sur l'icone "Image" dans la barre d'outil de l'éditeur CKEditor
    2. Cliquer sur le bouton "Explorer le server" pour choisir l'image à afficher
    3. Cocher la case "Agrandir l'image"
    4. Régler les dimensions de l'image pour réduire la taille de l'image affichée (et les autres paramètres si nécessaire)
    5. Cliquer sur le bouton "Ok" et sauvegarder votre article.

    ckeditor_lightbox.jpg

    Retourner sur votre site.
    En cliquant sur l'image, l'effet de zoom Lightbox affichera l'image avec ses dimensions originales.


    Astuce:
    A partir du gestionnaire de médias de PluXml, envoyer une image sur le serveur à partir du bouton "Ajouter des fichiers".
    Choisir les tailles de redimensionnement de l'image et de sa miniature.
    Dans CKEditor à partir de l'icone "Image", ajouter comme image la miniature (exemple: mon_image.tb.jpg).
    PluXml affichera la miniature sur votre site (fichier: mon_image.tb.jpg)
    En cliquant dessus, c'est l'image originale qui sera affichée (fichier: mon_image.jpg, sans l'extension .tb)

    Consultant PluXml

    Ancien responsable du projet

  • Aucun changement pour moi, même en vidant le cache... :-( Je vais essayer avec la version 1.4.8
  • Non, même avec 1.4.8 le problème subsiste !
    Toujours le message : "Firefox ne sait pas ouvrir cette adresse car le protocole (kcact) n'est associé à aucun programme."
    Pas de succès non plus avec Chrome et Opera :-(
  • thidal a écrit:
    Non, même avec 1.4.8 le problème subsiste !
    Toujours le message : "Firefox ne sait pas ouvrir cette adresse car le protocole (kcact) n'est associé à aucun programme."
    Pas de succès non plus avec Chrome et Opera :-(

    Peux-tu regarder dans la console javascript de ton navigateur pour voir s'il y a des messages explicites ?

    Es-tu en local ou sur un hébergeur ?
    Es-tu derriere un firewall ?

    Consultant PluXml

    Ancien responsable du projet

  • Sur IE, j'obtiens ceci dans la console :
    SCRIPT438: L’objet ne gère pas la propriété ou la méthode « setAttribute »
    plugin.js?t=C6HH5UF, Ligne 1 Caractère 3840
    Sur Firefox, je ne sais pas afficher la console :-(
    Le site est chez l'hébergeur OUVATON
    Je ne sais rien de plus :-(
    Peut-être le plus simple serait pour moi de revenir à une version plus ancienne du plugin ??
Connectez-vous ou Inscrivez-vous pour répondre.