[PLUGIN] Gutuma pour Pluxml : module de gestion de newsletters

15678911»

Réponses

  • SudwebdesignSudwebdesign Membres
    16 janv. modifié
    Slt, juste pour dire que gutuma a été mis a jour en v2.2

    CodeMirror et le gestionnaire de média sont de la partie lors de l'édition des infolettres ;)

    Nouveaux Messages de retours et est rendu + compatible avec PluXml 5.7 ;)
    changelog a écrit:
    ## v2.2.0 16/01/2019 ##
    [+] composer lettre* : Auto sauvegarde amélioré (compose.php + overlay)
    [+] *media manager : gestionnaire de media natif de PluXml pour l'insert d'images et de médias (tinyMCE de compose.php)
    [+] *Langue : L_NO_JS_STORAGE : classe du plugin gutuma.php : pour le systeme du gestionnaire de media (tinyMCE de compose.php)
    [+] *MAJ : Tinymce : 4.7.10 (2018-04-03) ==> 4.9.0 (2018-11-27)
    [+] *codemirror.5.42.2 (21-12-2018) (tinyMCE de compose.php)
    [+] Aide (fr) : Fichier d'exemple (Une page statique a copié) + conseils peaufinés
    : : page statique subscribe est compatible avec la réécriture d'url :)
    [+] subscription.php
    : : Messages de la première (fr & en) retouchés (1st In/Out messages)
    : : Fins de ligne unifiés des message (courriels) : $EOL = "\r\n" + $HR (72 =)
    : : Moins de sauts de ligne
    : : Norme des courriels : Fin de ligne des messages de LF à CRLF (\n --> \r\n)
    Fix inc/_pluxml.php : si connecté avec un compte inferieur a gestionnaire : ajax, gadget et subscribe(.php) Bloqué (erreur FrontEnd)
    Fix : image du menu theme 5.3.1 bonne taille avec compose.php, non les autres menu :: graçe a sa règles css "inline" img {height: auto !important;max-width: 100% !important;} theme default 5.3.1
    Fix : Warning: is_dir(): open_basedir restriction in effect. File(..) is not within the allowed path(s) : in gutuma/news/inc/list.php on line 367
    if ($file[0] != ".") //fix Warning: is_dir(): open_basedir restriction in effect. File(..)
    Fix : Notice: A non well formed numeric value encountered in gutuma/news/inc/list.php on line 368 and on line 278
    https://forum.pluxml.org/viewtopic.php?pid=57616#p57616

    @+

    Notre temps est la seule monnaie vraie ;)

    Site - Dépôt - MyShop

  • Bonjour,
    Je rencontre un soucis d'envoie de SMTP.

    Hébergement LWS
    J'ai tout éssayé :
    localhost
    mail.*******.org
    SSL TSL , etc
    J'ai resaisi le mot de passe plusieurs fois, bref


    J'utilise Humhub sur ce même site, et l'envoie par SMTP fonctionne parfaitement bien.
    Si quelqu'un à une piste ...
    MErci
  • SudwebdesignSudwebdesign Membres
    24 janv. modifié
    stevanovich a écrit:
    Si quelqu'un à une piste ...MErci
    Slt @tous, @toutes et @stevanovich ;)

    Il y a à dispo une Maj du mailer de gutuma (en phase de test) sur la page du plugin de mon site
    Pour passer de swiftmailer 3.3.2 à 4.3.1.
    Avec j'ai réussit (1 fois et de nuit) 2 envois SMTP [del]avec free.fr ;)[/del]

    [del]Serveur : smtp.free.fr
    Port : 587
    cryptage : aucun[/del]

    S'il y a des bidouilleurs, dite si elle fume chez vous :)

    [édit: 24/01/2019] en fait non, cela donne de belles erreurs 500 chez Free (oublié de décocher sendMail)
    Cela tourne (reçoit bien les courriels) en local avec un fake smtp server et juste smtp de coché :)
    Il manque le système de connexion multiples, il semble que cette fonctionnalité ai été retiré depuis la v4 de swift :o
    C'est possible que cela soit un pourquoi que le dev initiateur de gutuma ait arrêté son évolution...?
    @+

    Lisez-moi a écrit:

    #Mise a jour du mailer de gutuma v2.2.0 : swift 3.3.2 >>> 4.3.1

    #stade : Bêta

    Précaution : gutuma/news/inc/mailer.php : sauvegarder le fichier gutuma/news/inc/mailer.php en le renommant au préalable en mailer.3.3.2.php est une bonne idée

    Extraire le contenus du zip dans le dossier "news" du plugin gutuma

    Ce qui donne : (en plus des fichiers déja présents)

    gutuma/news/inc/swiftmailer-4.3.1/*
    gutuma/news/inc/mailer.php
    gutuma/news/inc/mailer-3.3.2-[v2.2.0].php

    Notre temps est la seule monnaie vraie ;)

    Site - Dépôt - MyShop

  • SudwebdesignSudwebdesign Membres
    27 janv. modifié
    S@lux

    Après quelques pérégrinations avec swift que je pense abandonné, j'ai décidé de voir ce que cela donne avec PHPMailer ;)

    Voici la MAJ compatible php 5.0 & php 5.5+ si besoin et disponible dans sa page dédié sous le jolis nom de gutuma.maj.inc_PHPMailers.RC00-2.2.02.zip :)

    @stevanovich, peut-etre que cela fera le taf ;)

    [édit] Fait pour compatible avec toute version de gutuma, enfin j’espère :)

    ps: le smtp de test utilisé : http://nilhcem.com/FakeSMTP/
    ps²: le readme est peaufiné ;)

    Notre temps est la seule monnaie vraie ;)

    Site - Dépôt - MyShop

Connectez-vous ou Inscrivez-vous pour répondre.